View Single Post
  #6 (permalink)  
Old May 14th, 2004, 12:25 PM
Imar's Avatar
Imar Imar is offline
Wrox Author
Points: 71,164, Level: 100
Points: 71,164, Level: 100 Points: 71,164, Level: 100 Points: 71,164, Level: 100
Activity: 100%
Activity: 100% Activity: 100% Activity: 100%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 16,960
Thanks: 79
Thanked 1,559 Times in 1,536 Posts
Default

Well, in that case, I assume your Web app folder is a subfolder of the wwwroot folder.

By default, the default web site points to C:\Inetpub\wwwroot. So, that's the root folder when you go to http://localhost for example.
Any folder inside wwwroot is "just another folder" unless you mark it as a virtual directory using the Create button on the Properties dialog for the folder. Then the "normal folder" changes to a VD. In your case, that seems to be the situation.

You can also map a VD from a different location. Using the VD wizard, you can map C:\MyWebSite to /MyApplication, so when you request http://localhost/MyApplication, the files are actually coming from C:\MyWebSite, and not from C:\Inetpub\wwwroot\MyApplication.

But this still doesn't clarify the problems with the validation files, and honestly, I am as stumped as you are.
When you reinstalled the .NET framework, did you also delete all the config folders and other .NET related stuff? Maybe you broke a config file somewhere, although I find that hard to believe....

Strange, very strange.

Cheers,

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
While typing this post, I was listening to: Crimes by A Perfect Circle (Track 8 from the album: Thirteenth Step) What's This?