View Single Post
  #6 (permalink)  
Old November 4th, 2004, 04:48 PM
asomani asomani is offline
Registered User
 
Join Date: Nov 2004
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
quote:Originally posted by r.cicca
 I had the same exactly problem and today I didn't find a solution.
Did you had find a solution?
Thanks,
Abhishek

Quote:
quote:Originally posted by gdelia1
 Hi there,

I got a problem using an MS Access database through ASP.NET.

After updating my system from .NET Framework 1.0 to 1.1, my existing
application gives me the following error when opening a connection
with the code below:

"Unspecified error" (ErrorCode: -2147467259)

string connectionStringKey = "LocalDBConnectionString";
string connectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Data
Source=C:\InetPub\wwwroot\IS_Italy_2003\IS.mdb";

OdbcConnection connection = new OdbcConnection(connectionString);
try    
{
connection.Open();
}
catch (OdbcException ex)
{
string error = ex.Message;
}
finally
{
connection.Close();
}

What's really strange is that:
1. The same application works on some of my colleagues' computers with
the .net Framework 1.1
2. The very same code works on my computer when creating a brand new
application with VS.NET 2003
3. The same application was working with .NET Framework 1.0

The same thing happens (including the two cases above) when using ODBC
classes instead of OleDB ones. In this case the connection string is:

"FIL=MS Access;DSN=AIS_Local"
 
and the error is:

"ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver] Disk or
network error.\r\nERROR [IM006] [Microsoft][ODBC Driver Manager]
Driver's SQLSetConnectAttr failed\r\nERROR [HY000] [Microsoft][ODBC
Microsoft Access Driver] Disk or network error."

Need HELP!!!
tks

Reply With Quote