View Single Post
  #9 (permalink)  
Old August 19th, 2006, 07:21 AM
Codescribler Codescribler is offline
Registered User
 
Join Date: Apr 2006
Location: , , United Kingdom.
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I Imar,

I wonder if you could work your magic on the same symptom but a different cause?

The error:
The 'System.Web.Security.SqlMembershipProvider' requires a database schema compatible with schema version '1'. However, the current database schema is not compatible with this version. You may need to either install a compatible schema with aspnet_regsql.exe (available in the framework installation directory), or upgrade the provider to a newer version.

What I have done:
1. Developed site and DB localy - they work
2. Created empty db via a SQL compare tool from Red Gate on my hosting account
3. Ran the aspnet_regsql.exe against my live db. - It worked
4. Ran my site localy but with a changed web.config to point to the new DB
5. Came up with the above error.
6. Read this forum post and checked the table which was fine and had all the data in it you said to check.

Not sure what to do now,

Any ideas?

Danny


Danny