View Single Post
  #3 (permalink)  
Old January 22nd, 2008, 03:46 AM
ismailc ismailc is offline
Friend of Wrox
 
Join Date: Jan 2007
Location: durban, Africa, South Africa.
Posts: 115
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi, - i think i'm kind of screwed as i think when it first loads the xslt loads the aspx file then it fine - i can refresh the page it's okay but i loose my inserted values. Once the page is loaded & click on an autopost event then it executes a javascript funtion that kind of only load the objects & not the entire page then the tooltip is out!

i know it's a lot but i have to get this going!

The xslt file loads this aspx file that - on autopost call a jscript function


[u]ASPX File</u>

<%@ Register TagPrefix="uc1" TagName="MainMenu" Src="MainMenu.ascx" %>
<%@ Register TagPrefix="uc1" TagName="Header" Src="Header.ascx" %>
<%@ Page language="c#" AspCompat="true" Codebehind="myProcessItem.aspx.cs" AutoEventWireup="false" Inherits="FlowCentric.Net.Navigator.myProcessItem" smartNavigation="True" enableViewStateMac="False" debug="False" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <HEAD>
        <title>myProcessItem</title>
        <META http-equiv="Content-Type" content="text/html; charset=windows-1252">
        <LINK href="skins/<% =Session["skin"] %>/styles.css" type="text/css" rel="stylesheet">
        <meta content="Microsoft Visual Studio .NET 7.1" name="GENERATOR">
        <meta content="C#" name="CODE_LANGUAGE">
        <meta content="JavaScript" name="vs_defaultClientScript">
        <meta content="http://schemas.microsoft.com/intellisense/ie5" name="vs_targetSchema">
    </HEAD>
    <body>
        <form id="Form1" method="post" encType="multipart/form-data" runat="server">
            <uc1:header id="Header1" runat="server"></uc1:header><uc1:mainmenu id="MainMenu1" runat="server"></uc1:mainmenu>
            <table class="tbDetail" width="100%">
                <tr>
                    <td class="wrnHead"><asp:label id="lblMessage" runat="server"></asp:label></td>
                </tr>
                <tr>
                    <td class="row1"><asp:label id="lblName" runat="server"></asp:label></td>
                </tr>
            </table>
            <asp:placeholder id="plc" runat="server" EnableViewState="False"></asp:placeholder>
            <table class="tbDetail" width="100%">
                <tr>
                    <td class="wrnHead"><asp:label id="lblMessage2" runat="server"></asp:label></td>
                </tr>
            </table>
</form></body></HTML>



[u]View the source it calls the foll funtion:</u>

<script language="javascript" type="text/javascript">
<!--
    function __doPostBack(eventTarget, eventArgument) {
        var theform;
        if (window.navigator.appName.toLowerCase().indexOf("m icrosoft") > -1) {
            theform = document.Form1;
        }
        else {
            theform = document.forms["Form1"];
        }
        theform.__EVENTTARGET.value = eventTarget.split("$").join(":");
        theform.__EVENTARGUMENT.value = eventArgument;
        theform.submit();
    }
// -->
</script>
<script type="text/javascript" src="/ig_common/20043/scripts/ig_csom.js" ></script>
<script type="text/javascript" src="/ig_common/20043/scripts/ig_webmenu.js" ></script>
<script language="JScript" type="text/JScript" src="/aspnet_client/system_web/1_1_4322/SmartNav.js"></script>



Reply With Quote