View Single Post
  #1 (permalink)  
Old August 29th, 2016, 03:05 AM
kanhaiya kanhaiya is offline
Registered User
Points: 3, Level: 1
Points: 3, Level: 1 Points: 3, Level: 1 Points: 3, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default set up xmpp server

hello everyone,

I am following the book professional programming with jquery and javascript. The hello example is working fine . But when I try to change the URL "http://bosh.metajack.im:5280/xmpp-httpbind" with my local server http://localhost:7070/http-bind/ nothing is happening.

I have installed openfire and using the built BOSH connection manager. I have defined the crossdomain.xml file also.

when I run hello.html on browser I see only three xml response

first response -
<body xmlns="http://jabber.org/protocol/httpbind" xmlns:stream="http://etherx.jabber.org/streams" from="10.222.12.73" authid="14h3ztjg0o" sid="14h3ztjg0o" secure="true" requests="2" inactivity="30" polling="5" wait="60" hold="1" ack="3247935772" maxpause="300" ver="1.6">
<stream:features>
<mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
<mechanism>DIGEST-MD5</mechanism>
<mechanism>SCRAM-SHA-1</mechanism>
<mechanism>PLAIN</mechanism>
<mechanism>ANONYMOUS</mechanism>
<mechanism>CRAM-MD5</mechanism>
</mechanisms>

second response
<body xmlns="http://jabber.org/protocol/httpbind" ack="3247935773">
<challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09IjEwLjIyMi4xMi43MyIsbm9uY2U9IjVTdU03 U2VCYzIrck9qS0NRY3lxSndYWko4OTdtcWV5WFFuVlRtZFkiLH FvcD0iYXV0aCIsY2hhcnNldD11dGYtOCxhbGdvcml0aG09bWQ1 LXNlc3M=</challenge>
</body>

third response
<body xmlns='http://jabber.org/protocol/httpbind' ack='3247935774'><failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure></body>


Can someone help me how to configure the server. I am using apache server