p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

asp_cdo thread: Jmail attachment appears as huge code block in email body


Message #1 by "Trevor Stevenson-Reid" <trevor@s...> on Fri, 14 Mar 2003 11:48:54
I'm trying to send an email with a Word .doc as an attachment but it 
turns up with the attachment encoded within the email body instead of 
attached. code is like:
<%
strFilePath = Server.MapPath("questionnaire.doc")

Set JMail = Server.CreateObject("JMail.SMTPMail") 
JMail.ServerAddress = "mail.address.co.nz"
JMail.Sender = "info@a..."
JMail.Subject = "Evaluation of ESSNZ"
JMail.AddRecipient "person@a..."
JMail.AddRecipientBCC "webmaster@e..."
JMail.ContentType = "text/html"
JMail.Body = "message"
JMail.AddAttachment(strFilePath)
JMail.Execute
%>

Why won't it work?
Message #2 by "Trevor Stevenson-Reid" <trevor@s...> on Sun, 16 Mar 2003 20:29:15
I'm trying to send an email with a Word .doc as an attachment but it 
turns up with the attachment encoded within the email body instead of 
attached. code is like:
<%
strFilePath = Server.MapPath("questionnaire.doc")

Set JMail = Server.CreateObject("JMail.SMTPMail") 
JMail.ServerAddress = "mail.address.co.nz"
JMail.Sender = "info@a..."
JMail.Subject = "Evaluation of site"
JMail.AddRecipient "person@a..."
JMail.AddRecipientBCC "webmaster@a..."
JMail.ContentType = "text/html"
JMail.Body = "message"
JMail.AddAttachment(strFilePath)
JMail.Execute
%>

Why won't it work?

  Return to Index