p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

aspx thread: Re: VS.Net Error


Message #1 by Feduke Cntr Charles R <FedukeCR@m...> on Wed, 10 Jul 2002 10:47:46 -0400
Guys,

> "The file 'c:\inetpub\wwwroot\OBISWEB\BL_TYP.dll' cannot be copied to the 
> run directory."

	Just had this problem myself.  Check your project references -
apparently VS.NET added a reference from the project to itself for reasons
unknown to me.  By removing the reference to itself it compiled fine again.
When making a DLL, the references are loaded into memory and the old DLL is
deleted so the new one can be created in its place - but if the old DLL is
referenced then this conflict occurs.

	Also make sure you don't have any project circular dependencies if
you are working with more than one project.  If project A references project
X then project X cannot reference project A for the same reasons mentioned
above.

- Chuck

-----Original Message-----
From: Sedef Orhan [mailto:sedefo@k...]
Sent: Friday, May 31, 2002 8:59 AM
To: ASP+
Subject: [aspx] Re: VS.Net Error


hi,
we have the same problem and it just appeared all of a sudden. we have 
been working on a project for almost two months using VS.NET with VSS. but 
all of a sudden VS.NET started giving these errors saying

"The file 'c:\inetpub\wwwroot\OBISWEB\BL_TYP.dll' cannot be copied to the 
run directory."  

we need help very urgently. if anyone knows the solution could you please 
let us know? we beg you!!!!

> process cannot access the file because it is being used by another
> process'.
>  
> Hi,
>  
> I am building a ASP.Net web application - I am using VS.net as my IDE
> and my localhost.  I have been getting this very frustrating error the
> second time I  try and rebuild my application (from a fresh reboot) 
>  
> "The file '\bin\myproj.dll' cannot be copied to the run directory.  The
> process cannot access the file because it is being used by another
> process'.
>  
> I have tried :
> 1. Stopping the webserver 
> 2. Deleting the file manually from my bin directory (get the same error)
> 3. clearing my ASP.net web cache
> 3. Deleting objects referencing my web site in COM+
>  
> Does any one have a work around other than a reboot?
>  
> Thanks
>  
> David
> 
> 

  Return to Index