p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

crystal_reports thread: Re: CRAXDRT Errors via the ActiveX web pages :(


Message #1 by "Smita Agarwal" <s.agarwal@s...> on Tue, 18 Feb 2003 13:41:36
> 
I'm experiencing exactly the same problem. I changed the code as you 
suggested but with no effect. The only bit that I did differently was put 
rptserver.asp where you've put reportname.rpt. 
Before I started getting this error, it was just excel exporting that 
wasn't working but now exporting doesn't work altogether. 
Do you have any further suggestions? I'm desperate

Smita



> I changed the line in the code:
 >  webSource.URL = "rptserver.asp"
t> o:
 >  webSource.URL = "http://Server_Host/Virtual_Directory/ReportName.rpt"

> I still don't know why this works, however....  

> IanS
Message #2 by "Smita Agarwal" <s.agarwal@s...> on Mon, 24 Feb 2003 10:04:29
After a lot of messing around I've solved this problem. The offending line 
of code was in the asp which is calling the report. Right at the end of 
the asp code, there was a line which said something along the lines 
of 'set "ORpt" = nothing'. I deleted this line and it all started working 
again. Hope this is of help to somebody.

Smita
> > 
I> 'm experiencing exactly the same problem. I changed the code as you 
s> uggested but with no effect. The only bit that I did differently was 
put 
r> ptserver.asp where you've put reportname.rpt. 
B> efore I started getting this error, it was just excel exporting that 
w> asn't working but now exporting doesn't work altogether. 
D> o you have any further suggestions? I'm desperate

> Smita

> 

> > I changed the line in the code:
 > >  webSource.URL = "rptserver.asp"
t> > o:
 > >  webSource.URL = "http://Server_Host/Virtual_Directory/ReportName.rpt"

> > I still don't know why this works, however....  

> > IanS

  Return to Index