Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP.NET 2.0 > ASP.NET 2.0 Professional
Password Reminder
Register
Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
ASP.NET 2.0 Professional If you are an experienced ASP.NET programmer, this is the forum for your 2.0 questions. Please also see the Visual Web Developer 2005 forum.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 2.0 Professional section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Display Modes
  #1 (permalink)  
Old September 5th, 2007, 05:25 PM
Authorized User
 
Join Date: Mar 2007
Location: , , .
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default ClientScript.GetCallbackEventReference() problem

I'm trying to do a callback and I'm having a slight problem with the GetCallBackEventReference() method, below is my method:

 this.ClientScript.GetCallbackEventReference(this, "getValues", "applyResult", null);

The problem I'm having is the second parameter ("getValues"), this is the parameter used to pass a value from the client to the server. Instead of stating an explicitly value I've specified a JavaScript function called getValues which returns a value back to the call, at least that is what I set it up to do but what I'm finding is that instead of the returned value being passed to the server the actual JavaScript function in full is being passed to the server, in other words the JavaScript function doesn't actually execute instead the function itself becomes the passed up parameter.

So my question: is there anyway to set up the second parameter so it actually runs the JavaScript code? I've tried adding the return keyword to the front but this doesn’t work.

 Any help much appreciated.

Thanks


 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Page.ClientScript.RegisterStartupScript & Threads VerbatimBOT ASP.NET 2.0 Professional 0 July 23rd, 2008 06:39 AM
ClientScript. : window.open -> Popup Blocker Issue AbrarNazeer ASP.NET 2.0 Professional 3 September 20th, 2006 10:59 AM
MasterPage and ClientScript jmcpeak ASP.NET 2.0 Professional 3 November 7th, 2005 02:27 PM



All times are GMT -4. The time now is 09:22 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.