Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: Beginning ASP.NET 4.5.1 : in C# and VB
This is the forum to discuss the Wrox book Beginning ASP.NET 4.5.1: in C# and VB by Imar Spaanjaars; ISBN: 978-1-118-84677-3
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Beginning ASP.NET 4.5.1 : in C# and VB section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old January 6th, 2017, 10:13 AM
Registered User
Points: 65, Level: 1
Points: 65, Level: 1 Points: 65, Level: 1 Points: 65, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2016
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Chapter 10 flickerFree Pages

Hello,

After following all of the steps, I'm stuck.

When I fill out the contact form, I no longer get the Message Sent nor is it showing any "Please wait..." with the gif. Can't figure out what's causing this. I'll upload my files. This is a brain-scratcher...

Thanks in Advance,
Se7eN

File:
http://s000.tinyupload.com/?file_id=...05695530717839
Reply With Quote
  #2 (permalink)  
Old January 6th, 2017, 11:58 AM
Imar's Avatar
Wrox Author
Points: 71,054, Level: 100
Points: 71,054, Level: 100 Points: 71,054, Level: 100 Points: 71,054, Level: 100
Activity: 100%
Activity: 100% Activity: 100% Activity: 100%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 16,927
Thanks: 79
Thanked 1,553 Times in 1,530 Posts
Default

Try looking at the browser's debug bar (like FireBug in FireFox). Does it show an error?

Also, try removing the UpdatePanel and its template wrapper. Do you get an error then?

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
  #3 (permalink)  
Old January 6th, 2017, 12:09 PM
Registered User
Points: 65, Level: 1
Points: 65, Level: 1 Points: 65, Level: 1 Points: 65, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2016
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the error I see in the Console Dev Tools of Chrome:
Uncaught Error: Sys.WebForms.PageRequestManagerServerErrorExceptio n: Could not find a part of the path 'G:\School Work\Server-Side Scripting\Chapter 10\begASPNET\App_Data\ContactForm.txt'.
at Function.Error$create [as create] (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:237)
at Sys$WebForms$PageRequestManager$_createPageRequest ManagerServerError [as _createPageRequestManagerServerError] (ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:656)
at Sys$WebForms$PageRequestManager$_parseDelta [as _parseDelta] (ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:1534)
at Sys$WebForms$PageRequestManager$_onFormSubmitCompl eted [as _onFormSubmitCompleted] (ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:1314)
at Array.<anonymous> (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:47)
at ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:3484
at Sys$Net$WebRequest$completed [as completed] (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:6376)
at XMLHttpRequest.Sys$Net$XMLHttpExecutor._onReadySta teChange (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:5996)
ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:885 Uncaught Error: Sys.WebForms.PageRequestManagerServerErrorExceptio n: Could not find a part of the path 'G:\School Work\Server-Side Scripting\Chapter 10\begASPNET\App_Data\ContactForm.txt'.
at Function.Error$create [as create] (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:237)
at Sys$WebForms$PageRequestManager$_createPageRequest ManagerServerError [as _createPageRequestManagerServerError] (ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:656)
at Sys$WebForms$PageRequestManager$_parseDelta [as _parseDelta] (ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:1534)
at Sys$WebForms$PageRequestManager$_onFormSubmitCompl eted [as _onFormSubmitCompleted] (ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:1314)
at Array.<anonymous> (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:47)
at ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:3484
at Sys$Net$WebRequest$completed [as completed] (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:6376)
at XMLHttpRequest.Sys$Net$XMLHttpExecutor._onReadySta teChange (ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUO ReY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:5996)
Error$create @ ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:237
Sys$WebForms$PageRequestManager$_createPageRequest ManagerServerError @ ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:656
Sys$WebForms$PageRequestManager$_parseDelta @ ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:1534
Sys$WebForms$PageRequestManager$_onFormSubmitCompl eted @ ScriptResource.axd?d=JnUc-DEDOM5KzzVKtsL1td-jdCnQPNBtKPugwa2i3xU_VG37MeEhYK7kZ4Dfu2-YQ-gKia2a0B_1Ii:1314
(anonymous) @ ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:47
(anonymous) @ ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:3484
Sys$Net$WebRequest$completed @ ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:6376
Sys$Net$XMLHttpExecutor._onReadyStateChange @ ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQpauBMUOR eY-43kJ8H2W6xAfaXI-MGVcrveJqL-6QT1HgtTrhi36cm0b4T:5996

After removing the UpdatePanel and Template, then erased the AssociatedPanel, I get this error when sending in contact form:

http://tinypic.com/r/1zzhysl/9
Reply With Quote
  #4 (permalink)  
Old January 6th, 2017, 03:11 PM
Imar's Avatar
Wrox Author
Points: 71,054, Level: 100
Points: 71,054, Level: 100 Points: 71,054, Level: 100 Points: 71,054, Level: 100
Activity: 100%
Activity: 100% Activity: 100% Activity: 100%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 16,927
Thanks: 79
Thanked 1,553 Times in 1,530 Posts
Default

That's a pretty obvious error, no? Or do you really want me to ask "And is the error message correct? Does the file indeed not exist? If not, you need to create it. Also, make sure you check the spelling"?

If so, here goes:

"And is the error message correct? Does the file indeed not exist? If not, you need to create it. Also, make sure you check the spelling".

;-)

Cheers,

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
  #5 (permalink)  
Old January 7th, 2017, 09:33 AM
Registered User
Points: 65, Level: 1
Points: 65, Level: 1 Points: 65, Level: 1 Points: 65, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2016
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's the thing, The file does exist, in the proper place, and is named correctly. If that's the case, then what's the problem?
Reply With Quote
  #6 (permalink)  
Old January 7th, 2017, 10:12 AM
Imar's Avatar
Wrox Author
Points: 71,054, Level: 100
Points: 71,054, Level: 100 Points: 71,054, Level: 100 Points: 71,054, Level: 100
Activity: 100%
Activity: 100% Activity: 100% Activity: 100%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 16,927
Thanks: 79
Thanked 1,553 Times in 1,530 Posts
Default

>> That's the thing, The file does exist, in the proper place, and is named correctly. If that's the case, then what's the problem?

Maybe it exists, but it sure isn't in the proper place. Just look at your App_Data folder. Is it really called App_Data?

The easiest way to test out stuff like this is to copy the path from the error and paste it in File Explorer in Windows. You'll see you get an error instead of the file being opened which should lead you to to the error and its solution.

Cheers,

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
  #7 (permalink)  
Old January 7th, 2017, 12:31 PM
Registered User
Points: 65, Level: 1
Points: 65, Level: 1 Points: 65, Level: 1 Points: 65, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2016
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you, I found the issue, it's my dyslexia. I appreciate the help. Trying to do all this without instruction from my professor. Currently in break of school and decided to get a head start on our assignments.

Now I'm able to get Message Sent, but I'm not getting the Please Wait Loading icon. I'm trying to compare mine with the Source version and they look to be identical, but still not showing the loading. Any ideas what may be the cause of the problem?
Reply With Quote
  #8 (permalink)  
Old January 7th, 2017, 04:03 PM
Imar's Avatar
Wrox Author
Points: 71,054, Level: 100
Points: 71,054, Level: 100 Points: 71,054, Level: 100 Points: 71,054, Level: 100
Activity: 100%
Activity: 100% Activity: 100% Activity: 100%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 16,927
Thanks: 79
Thanked 1,553 Times in 1,530 Posts
Default

Could it be the cache? Did you try reloading the browser using Ctrl+F5?

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
  #9 (permalink)  
Old January 7th, 2017, 04:28 PM
Registered User
Points: 65, Level: 1
Points: 65, Level: 1 Points: 65, Level: 1 Points: 65, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2016
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I have tried doing so. Still no luck. Can I upload my Chapter 10 folder to you to check if it works for you?
Reply With Quote
  #10 (permalink)  
Old January 7th, 2017, 04:32 PM
Registered User
Points: 65, Level: 1
Points: 65, Level: 1 Points: 65, Level: 1 Points: 65, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2016
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

If so, here is the uploaded files:

http://s000.tinyupload.com/?file_id=...52369922581300

I used tinyupload because I believe that's the one that works for you.

I tried clearing the cache again using Ctrl + F5 and still not getting the Please Wait logo. Everything I've tried has returned zero results.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Chapter 10 Tijuana BOOK: Beginning ASP.NET 3.5 : in C# and VB BOOK ISBN: 978-0-470-18759-3 2 August 11th, 2012 07:15 AM
Chapter 10 mahmed55 BOOK: Beginning iOS 4 Application Development 2 December 6th, 2011 07:19 PM
chapter 10 ex 1 poldeleeuw BOOK: Stephens' C# Programming with Visual Studio 2010 24-Hour Trainer 2 December 23rd, 2010 06:15 AM
Chapter 10, listing 10-10-app kiwibrit BOOK: Professional ASP.NET 3.5 : in C# and VB ISBN: 978-0-470-18757-9 2 August 18th, 2009 04:21 AM
Some variable dissapear after goin tru 10 pages Monkeycoder Beginning PHP 4 January 5th, 2005 06:46 PM



All times are GMT -4. The time now is 08:37 AM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2013 John Wiley & Sons, Inc.