do_time vs do_timer
For those following along in the code...if you are looking for the function do_time, you won't find it...you will, however, find do_timer.
On page 898 - 899:
3rd, line, first bullet reads "do_time is responsible..." It should read "do_timer is responsible..."
Figure 15-4 is correct, mentioning do_timer. However, the single line paragraph below it, "First, consider do_time..." should be modified to "First, consider do_timer..."
Figure 15-5 also refers to do_time rather than do_timer.
Great book, by the way. An audacious and pretty-much successful attempt to describe a huge, self-referential, complex mass of code. Mr. Maurerer is to be congratulated!