Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: Professional Microsoft Office SharePoint Designer 2007 ISBN: 978-0-470-28761-3
This is the forum to discuss the Wrox book Professional Microsoft Office SharePoint Designer 2007 by Woodrow W. Windischman, Bryan Phillips, Asif Rehmani; ISBN: 9780470287613
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Professional Microsoft Office SharePoint Designer 2007 ISBN: 978-0-470-28761-3 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old April 20th, 2010, 10:40 AM
Registered User
 
Join Date: Apr 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy CH15: Example not working

I followed the example in ch 15 to create a new workflow step that is exposed in Sharepoint Designer. Since I can't figure out how to debug my DLL (little green getting back into Visual Studio, last time I played was VB6 - I know, I know, but I'm learning), I'm stuck at this point.

Everything seems to function properly with respect to the rest of the setup. my .ACTIONS file seems fine, it gets exposed properly. I can use the step in a workflow and set all the properties and check it and save it. I can run the workflow, but it 'always' returns:

Object reference not set to an instance of an object.

Which is an entirely separate pet peeve I have with workflow error reporting in Sharepoint, but I'll let that go for now.

I tried adding a little comment like "Fred! " in front of ex.Message in the service.LogToHistoryList, but no go. I even tried adding calls to that at the beginning of my try command to see if I could log something simple before getting that 'run home to mamma' error, but no go.

Any ideas as to where the problem might be, or more importantly, tips on debugging this thing? Seems like I'm really close. I have downloaded and used other custom workflow elements that others have written, so I know they can be registered and work fine in my environment. I'm just failing on my end to do something.

Note: One thing that seems different between my environment and what the book would seem to indicate 'should' work occurs with figure 15-8. I don't get to just see those 3 things to add on my .NET tab. I had to go find the 3 DLLs I needed to pull down out of the server's ISAPI folder and then use the 'browse' button to navigate to where I saved the files locally and referenced them that way. Seems to compile fine, the references seem to work for the build, and presumably once I put my DLL up on the server and include it in the global assembly cache, the references will work with those registered on the server?

Side question: after each time I rebuild my DLL and copy it up to the server, do I have to uninstall it from the global assembly cache and drag it back into the GAC each time, or is it enough once it's included (so long as I throw my DLL out in the same folder) to simply do the iisreset?

Thank you for any assistance!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Working Code - Ch15 slurp56 BOOK: Professional PHP 5 ISBN: 978-0-7645-7282-1 3 April 24th, 2013 10:32 AM
Ch15 Workflow association example clubo BOOK: Professional SharePoint 2007 Development ISBN: 978-0-470-11756-9 1 January 19th, 2010 05:21 AM
Page 811; Ch15 Nick Y BOOK: Ivor Horton's Beginning Visual C++ 2005 0 July 24th, 2006 02:22 PM
Ch15 CodeBehind mahir BOOK: Beginning ASP.NET 1.0 2 May 8th, 2004 01:58 AM
ch15: can't get JSTL to be recognized brownale2k JSP Basics 1 August 8th, 2003 04:32 PM



All times are GMT -4. The time now is 11:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.