Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Microsoft Office > Other Office > Infopath
Password Reminder
Register
Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Infopath Programming and automation discussions only please. :)
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Infopath section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old July 15th, 2008, 07:26 AM
Registered User
 
Join Date: Jul 2008
Location: Bangalore, Karnataka, India.
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Making Infopath 2007 form browser compatible

Hi,

I am working on Infopath 2007 template having two views. One is request creation and other is approval. But when i checked my forms compatibility with the browser i got the error "User roles are not supported.". I thought may be some problem with my design and i am using some rules in UI and code which are not compatible. Then i removed my code first then i removed all of my controls one by one and then even some of the images and at last i removed everything so just blank forms in both views. But still i was getting the same irritating error even with empty forms and no code.:(
But when i am creating a new project with empty template the its working fine.
Can any one tell me what is the possible reason for that?
I will be very thankful.

Akash Kansal
__________________
Akash Kansal
Reply With Quote
  #2 (permalink)  
Old July 18th, 2008, 11:34 PM
Registered User
 
Join Date: Jul 2006
Location: Hyderabad, AP, India.
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,


User roles are not supported for browser forms. Can you please verify that, you have added any roles in the Toolsà “User roles” window?

Remove the roles from user roles window, then save and close the form. Again open the form in design mode and verify it.

Can you verify the below link if you want implement user roles in browser form.

http://blogs.msdn.com/infopath/archi...ser-forms.aspx



Anuma Reddy
http://www.GGKtech.com
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 09:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.