Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Other Programming > Other Programming Languages
Password Reminder
Register
Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Other Programming Languages If you have a coding issue to discuss about another language that really isn't provided for in any other forum here (not ASP.NET C#, C++, VB, PHP, JavaScript, Python, Java, Perl, Applescript, XML or any of the other forum topics we have), post it here. Enough discussion on a language we don't have covered could prompt a new forum.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Other Programming Languages section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developersí questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old October 21st, 2009, 07:26 AM
Registered User
 
Join Date: Oct 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Delphi printing oddities

Hi guys, first post here so be gentle :)

Im having some bother with printing in delphi and im wondering if anyone has come across the same issues that im having.

We create images of charts, lots of lines and shaded areas, all created on a delphi TMetafileCanvas, this is then sent to the printer in a page by page notion as defined by the setting of the printer.

Sometimes it works fine, sometimes it will just miss out a huge chunk of the image, like it will get halfway through a page and then literally just stop. Then on the next page draw everything fine. Its not even consistent in where it fails, you can print the exact same image after one that had failed and it will print out fine. The worst thing is there are no error messages shown either.

I had originally suspected some form of memory issue but everything seems to be getting disposed of and cleaned up correctly.

Does anyone have any suggestions or previous experience of this type of issue?

Regards

Ross
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Delphi coder transitioning to VS 2005 BabyToy VB Databases Basics 0 June 11th, 2007 06:17 AM
Controlling Speaker with Borland Delphi 6.0 Randhy Other Programming Languages 0 April 1st, 2006 07:02 AM
Delphi to C++ conversion. Need help... Neeko C++ Programming 2 December 20th, 2005 12:51 AM
AWSExpert for Builder/Delphi 5-6-7 sash2 C++ Programming 0 January 26th, 2005 09:15 AM
Delphi ADO Query acabrera Oracle 2 February 2nd, 2004 11:49 AM



All times are GMT -4. The time now is 07:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.