p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/)
-   Dreamweaver (all versions) (http://p2p.wrox.com/dreamweaver-all-versions-58/)
-   -   Uploading to Host (http://p2p.wrox.com/dreamweaver-all-versions/33344-uploading-host.html)

europhreak September 13th, 2005 01:21 AM

Uploading to Host
 
Please Help the newbie. I have started developing pages in dreamweaver and everything works great locally (win xp, iis is already set up). I have a hosting account at www.brinkster.com and would like to upload my pages and database to it. locally the site structure is as follows:
C:\inetpub\wwwroot\project,
in the project folder i have "bin" containing DreamweaverCtrls.dll file, then "database" folder with one databas and in "project" which is the root of my site are few aspx files and web.confi file. everything works great locally, but when i ftp-ed all those files and folder keeping the same site structure, whenever i try to open any aspx errors i get errors:
---------------------------------------------------------------------
Line 1: <%@ Page Language="VB" ContentType="text/html" ResponseEncoding="iso-8859-1" %>
Line 2: <%@ Register TagPrefix="MM" Namespace="DreamweaverCtrls" Assembly="DreamweaverCtrls,version=1.0.0.0,publicK eyToken=836f606ede05d46a,culture=neutral" %>
Line 3: <MM:Insert
Line 4: runat="server"


Source File: \\premfs19\sites\premium19\fibernex\webroot\projec t\testpage.aspx Line: 2

Assembly Load Trace: The following information can be helpful to determine why the assembly 'DreamweaverCtrls' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = DreamweaverCtrls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=836f606ede05d46a
 (Fully-specified)
LOG: Appbase = file://premfs19/sites/premium19/fibernex/webroot
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Publisher policy file is not found.
LOG: No redirect found in host configuration file (C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspn et.config).
LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g\machine.config.
LOG: Post-policy reference: DreamweaverCtrls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=836f606ede05d46a
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/0dece17d/9f402e6b/DreamweaverCtrls.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/0dece17d/9f402e6b/DreamweaverCtrls/DreamweaverCtrls.DLL.
LOG: Attempting download of new URL file://premfs19/sites/premium19/fibernex/webroot/bin/DreamweaverCtrls.DLL.
LOG: Attempting download of new URL file://premfs19/sites/premium19/fibernex/webroot/bin/DreamweaverCtrls/DreamweaverCtrls.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/0dece17d/9f402e6b/DreamweaverCtrls.EXE.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/0dece17d/9f402e6b/DreamweaverCtrls/DreamweaverCtrls.EXE.
LOG: Attempting download of new URL file://premfs19/sites/premium19/fibernex/webroot/bin/DreamweaverCtrls.EXE.
LOG: Attempting download of new URL file://premfs19/sites/premium19/fibernex/webroot/bin/DreamweaverCtrls/DreamweaverCtrls.EXE.
-------------------------------------------------------------------
is there anything i need to change as far as connecting/pointer to database. i know that when looking at code in dreamweaver there is no
-----------------------------------------------------------
<%

    Dim sPath As String = "C:\sites\single??\username\database\YourDB.md b"

    Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0; DATA Source=" & sPath & ";"

    Dim objConn As OleDbConnection

    Dim cmdSelect As OleDbCommand

    Dim dtrReader As OleDbDataReader

    Dim strResults As String



    objConn = New OleDbConnection( connString )



    objConn.Open()
--------------------------------------------------------------
all this is missing when using dreamweaver, why?, when i do provide all the connecting info then i get errors when trying to run this locally, why?, should this be added automatically by dreamweaver when you publish the site?.

Please help!!!


hastikeyvan September 17th, 2005 09:07 AM

what kind of error does it give t you?is it for your web config or the web config is working?


Lofa September 25th, 2005 10:58 AM

You have to know the direct address of the database where it is on the remote server and point on it.
Does the provider give opportunity to use asp.net pages and database. You have too consult the provider witch connection mode you have to use.

Dreamweaver publish the connection scripts automaticly if you have configure all right.



All times are GMT -4. The time now is 11:54 AM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
2013 John Wiley & Sons, Inc.