p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/)
-   ASP.NET 2.0 Basics (http://p2p.wrox.com/asp-net-2-0-basics-136/)
-   -   Problem with user controls (http://p2p.wrox.com/asp-net-2-0-basics/50304-problem-user-controls.html)

jamara November 14th, 2006 04:41 PM

Problem with user controls
 
Hi,
   Following code is generating error "Unrecognized Namespace "UIDUControl"" Can someone please show me what I am doing wrong? I am new to ASP.NET.
   The .ascx files are in the bin/App_code folder of my website.
Thanks!

Here's the code:

Imports System
Imports System.Web
Imports System.Web.UI
Imports System.Web.UI.WebControls
Imports System.Web.Caching



<% @Register TagPrefix="UIDUControl" TagName="Header" Src="ScanningAppHeader.ascx" %>
<% @Register TagPrefix="UIDUControl" TagName="Footer" Src="ScanningAppFooter.ascx" %>
<% @Register TagPrefix="UIDUControl" TagName="SAFunctions" Src="ScanningAppFunctions.ascx" %>

<% @Page Inherits="SAFunctions.SAFunct" Src="SAFunct.vb" %>

<html xmlns="http://www.w3.org/1999/xhtml">

<head>
<meta http-equiv="Content-Language" content="en-us"/>
<meta name="GENERATOR" content="Microsoft FrontPage 5.0"/>
<meta name="ProgId" content="FrontPage.Editor.Document"/>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252"/>

<title>Delete Units and All Associated Records</title>
<link rel="stylesheet" type="text/css" />

</head>
<body>
</body>
<script type="text/jscript" language="jscript">
function additional_delete(myform) {
    myform.action = "delete_unit_no.asp"
    myform.submit();
}


</script>

<UIDUControl:SAFunctions id="SAFunctions1" runat="server" >


<body>
<form name="myForm" method="POST" action="delete_unit_no.aspx">
<table width="100%">
    <tr>
        <td colspan="2" align="center">
        <UIDUControl:Header id="Header1" runat="server" />
        </td>
    </tr>
    <tr>
        <td width="10%" height="100%" bgcolor="#003399" valign="top">
                   <td width="90%" align="center">
               <table>
                    <tr align="center">
                        <td align="center">
                            <%

                                If(Len(Err.Description) > 0) Then
                                    Response.Write ("<p>Error. Please Check Input and Try Again.</p>")
                                    Response.Write ("<p>" & Err.Description & "</p>")
                                    Response.Write ("<p><input type=""Button"" onclick=""javascript:history.go(-1);"" value=""Go Back""></p>")
                                Else
                                    Response.Write ("<p><b>Record deleted from database!</b></p>")
                                    Response.Write ("<input type=""submit"" value=""Delete Another"" name=""B1"" tabindex=""3"">")
                                End If
                            %>
                            </td>
                    </tr>

                </table>
       </td>
    </tr>
</table>



<table>
  <tr>
        <td colspan="2" align="center" >
        <UIDUControl:Footer id="Footer1" runat="server" />
        </td>
    </tr>
</table>
 </form>
</body>
</html>



jamara November 15th, 2006 11:37 AM

Can anyone please help me on this? I have read every User Control posing in this site. I really cannot find the problem here. I've been looking at this for 3 days and am so very frustrated...besides being so very behind on my project now.



davidrodrigues40 November 15th, 2006 11:46 AM

Can you post the code for the whole page? From top to bottom including the <%@ Page %> tag.

David Rodrigues
"There is no box"

jamara November 15th, 2006 01:06 PM

Sure! And thanks for your assistance on this. Please note: the .ascx files reside on my D drive. in other pages, I've tried the full path in the register command but that doesn't work either.

Here's the page code:

Imports System
Imports System.Web
Imports System.Web.UI
Imports System.Web.UI.WebControls
Imports System.Web.Caching



<% @Register TagPrefix="UIDUControl" TagName="Header" Src="ScanningAppHeader.ascx" %>
<% @Register TagPrefix="UIDUControl" TagName="Footer" Src="ScanningAppFooter.ascx" %>
<% @Register TagPrefix="UIDUControl" TagName="SAFunctions" Src="ScanningAppFunctions.ascx" %>

<% @Page Inherits="SAFunctions.SAFunct" Src="SAFunct.vb" %>

<%
'Declare all variables

Dim strUsername, strPassword, strInstance
Dim strUIDNo, strSerNo, strPartNo1, strUIDType, strUIDTypeKey
Dim strPartNo, strKeyLen, startSN, strKey, strVKey
Dim oConn, oRst, mySQL, oRstNHA, boolDisplayOnly
Dim strUIDNo1
Dim ErrorEOF, ErrorEOF2
Dim ErrorDBText, ErrorDB

Const strSysName = "ScanApp%"

'If there is an error continue on the next line - comment next line for debugging
'On Error Resume Next

'Get the passed form variables and set other variables
strUsername = Request.Form("Username")
strPassword = Request.Form("Password")
strInstance = "c4sdev"
strKey = Request.Form("UnitKey")
strUIDType = Request.Form("UIDType")
strUIDNo = Request.Form("strUIDNo")

%>

<html xmlns="http://www.w3.org/1999/xhtml">

<head>
<meta http-equiv="Content-Language" content="en-us"/>
<meta name="GENERATOR" content="Microsoft FrontPage 5.0"/>
<meta name="ProgId" content="FrontPage.Editor.Document"/>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252"/>

<title>Delete All Associated Records</title>
<link rel="stylesheet" type="text/css" />

</head>
<body>
</body>
<script type="text/jscript" language="jscript">
function additional_delete(myform) {
    myform.action = "delete_unit_no.asp"
    myform.submit();
}


</script>

<UIDUControl:SAFunctions id="SAFunctions1" runat="server" ></UIDUControl:SAFunctions>



<%


If UCase(strUIDType) = "SCANAPP" Then
   getMatrixType (strKey, strUIDType, strUIDNo, strSerNo, strUIDTypeKey)
End if

DeleteUIDTree (strUIDNo)

%>
<form name="myForm" method="POST" action="delete_unit_no.aspx">
<table width="100%">
    <tr>
        <td colspan="2" align="center">
        <UIDUControl:Header id="Header1" runat="server"></UIDUControl:Header>
        </td>
    </tr>
    <tr>
        <td width="10%" height="100%" bgcolor="#003399" valign="top">

        </td>
        <td width="90%" align="center">
               <table>
                    <tr align="center">
                        <td align="center">
                            <%

                                If(Len(Err.Description) > 0) Then
                                    Response.Write ("<p>Error. Please Check Input and Try Again.</p>")
                                    Response.Write ("<p>" & Err.Description & "</p>")
                                    Response.Write ("<p><input type=""Button"" onclick=""javascript:history.go(-1);"" value=""Go Back""></p>")
                                Else
                                    Response.Write ("<p><b>Record deleted from database!</b></p>")
                                    Response.Write ("<input type=""submit"" value=""Delete Another"" name=""B1"" tabindex=""3"">")
                                End If
                            %>
                            </td>
                    </tr>

                </table>
       </td>
    </tr>
</table>
                <input type="hidden" value="<%=strUsername%>" name="Username"/>
                <input type="hidden" value="<%=strPassword%>" name="Password"/>
                <input type="hidden" value="<%=strKey%>" name="UnitKey"/>
                <input type="hidden" value="<%=strUIDType%>" name="UIDType"/>


<table>
  <tr>
        <td colspan="2" align="center" >
        <UIDUControl:Footer id="Footer1" runat="server" ></UIDUControl:Footer>
        </td>
    </tr>
</table>
 </form>

</html>


jamara November 15th, 2006 01:07 PM

I should add that the software and all other .aspx files are also on my D drive. I have no idea if that makes a difference...


davidrodrigues40 November 15th, 2006 04:29 PM

One thing I noticed is the UIDUControl:Header and footer. I am unaware of the included file and will probably need to see that code as well. One thing you could do is place the control inside a WebPartZone to achieve the same results.

David Rodrigues
"There is no box"

davidrodrigues40 November 15th, 2006 04:39 PM

Try reformating the register tag from <% @Register to <%@ Register

David Rodrigues
"There is no box"

jamara November 17th, 2006 04:34 PM

I have found the issue with the User Controls. It was because I had the software and files on my D drive. Once I reinstalled on the C drive, it worked fine except for .jsp and .html files (new post).



All times are GMT -4. The time now is 04:09 AM.

Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
2013 John Wiley & Sons, Inc.