Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > SharePoint > SharePoint Development
Password Reminder
Register
Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
SharePoint Development Programming and development for SharePoint Portal Server and Windows SharePoint Services
Welcome to the p2p.wrox.com Forums.

You are currently viewing the SharePoint Development section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developersí questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old March 1st, 2006, 08:41 AM
Registered User
 
Join Date: Mar 2006
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default WebPart & DataGrid

Hi all!

I am developing simple WebPart - it consists only from DataGrid control, wich will displays the list of employees, also this WebPart implements ICellProvider interfeace.

In CreateChildControls I'm creating my DataGrid using following code:

employeeList.AutoGenerateColumns = false;
employeeList.AllowPaging = true;
employeeList.AllowCustomPaging = true;
employeeList.PageSize = 10;

I've located my WebPart on Sharepoint portal page and everything seems fine. But the problem occurs when DatraGrid has more than 1 pages.

When User navigates throught pages using Pager in direct order (from 1st page to 2nd, from 2nd to 3rd) data is displayed correctly, but when user tries to navigate in reverse order (I mean from 3rd page to 2nd page) DataGrid opens 1st page filled with data from 3rd page.

First, I thought that I was made a mistake during DataGrid filling, but I have developed simple WebApplication and the same logic works fine on aspx page, the problem occurs only with WebPart.

Does anyone knows how to solve this problem?
Reply With Quote
  #2 (permalink)  
Old June 12th, 2006, 11:29 AM
Authorized User
 
Join Date: Nov 2005
Location: , , .
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to x_ray
Default

why dont you implement the webpart with user control?

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux & KDE & C++ & QT & MYSQL & Kdevelop Munnnki Linux 0 January 2nd, 2005 04:41 PM
Capturing Keyup & KeyDown in a Datagrid SupaHoopsa General .NET 3 October 11th, 2004 03:40 PM
DataGrid & Keyboard melvik C# 6 September 15th, 2004 12:35 AM
Looking for Datagrid Cols&Columns reyboy Pro VB.NET 2002/2003 1 May 25th, 2004 08:12 AM
Problem with DataGrid & JavaScript qadeer05 Classic ASP Basics 2 April 19th, 2004 10:28 AM



All times are GMT -4. The time now is 06:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.