View Single Post
  #5 (permalink)  
Old February 22nd, 2006, 01:37 PM
x_ray x_ray is offline
Authorized User
 
Join Date: Nov 2005
Location: , , .
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to x_ray
Default

ok, i have connected my pc to internet, i have windows xp, and i am using the following code to send the email from the form(it s simple, but doesn't work)(note that this is a portion, without the decalrations for space, if you need the whole code tell me)
Code:
<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
 <% Option Explicit %>
 <% 
'Get data from previous page
 sTo = Request("sTo") 
 sFrom = Request("sFrom") 
 sSubject = Request("sSubject")
 sTextBody = Request("sTextBody") 
 sHTMLBody = Request("sHTMLBody") 
 
'Only run this if it's not the first time 
 If Request.Form("Submit") <> "" Then
 
 Dim objMail 
 'Create the mail object 
 Set objMail = Server.CreateObject("CDO.Message")
 'Set key properties 
 objMail.From = sFrom 
 objMail.To = sTo 
 objMail.Subject= sSubject 
 objMail.TextBody = sTextBody 
 objMail.HTMLBody = sHTMLBody 
 
'Send the email 
 objMail.Send 
 'Set sMsg which will be used later 
 sMsg = "Your message was sent to: " & sTo 
 
 'Clean-up 
 Set objMail = Nothing
 
 End If 
%>
<html>
 <head><title>SendMail</title></head>
 <body>
  <form action="<%=Request.ServerVariables("PATH_INFO")%>" method="post">
  <table>
    <tr>
      <td>Send To:</td>
      <td><input type="text" name="sTo" value="<%=sTo%>"></td>
    </tr>
    <tr>
      <td>Send From:</td>
      <td><input type="text" name="sFrom" value="<%=sFrom%>"></td>
    </tr>
   <tr>
      <td>Message Subject:</td>
      <td><input type="text" name="sSubject" value="<%=sSubject%>"></td>
    </tr>
    <tr>
      <td>Message Text Body:</td>
      <td><textarea cols="60" rows="5" name="sTextBody">
         <%=sTextBody%></textarea></td>
    </tr>
    <tr>
      <td>Message HTML Body:</td>
      <td><textarea cols="60" rows="5" name="sHTMLBody">
         <%=sHTMLBody%></textarea></td>
    </tr>
    <tr>
      <td> </td>
      <td><input type="submit" name="Submit" value="Submit"></td>
    </tr>
  </table>

  <%=sMsg%>
  </form>
 </body>
 </html>

ok now when i submit, here is the error that i am getting:
CDO.Message.1 (0x80040220)
The "SendUsing" configuration value is invalid.
 what should i do? please i need help, any kind of help or suggestions( i googled a little, but i didn't understand anything of all this technical explanation about windows server... all i am using is windows xp with iis installed!!!)