View Single Post
  #1 (permalink)  
Old November 29th, 2004, 04:28 PM
charlietritran charlietritran is offline
Registered User
 
Join Date: Nov 2004
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default CAN NOT CONNECT TO SQL SERVER 2000 REMOTELY

HI Everyone,

I am having trouble with connecting to the sql server 2000 database located on the network.

I installed win2000 server and sql server 2000 database to the server machine ( new PC). Using an available network cable and plugged it to that PC. Then I did the upsizing an access database to the sql server database by moving all tables to that sql server. I can open the forms/tables of the access database that are linked to the sql server's ones locally. But it does not work when open them from a client machine, such as my machine.

For ex: I created a shared drive on the server PC and put the front-end access database in it. Go to my PC and map a network drive to that PC. Double click that access database on the mapped drive and would see all tables including the mapped ones. Then, I tried to open one of the mapped table and see a dialog :SQL Server Login. I put the server name ( used the same as the server PC's name) in the SERVER box, put a check for Using Trusted Conneciton and click OK. It seems to hang up for awhile and the error message is:

==================
SQLState: '01000'
SQL Server Error: 53
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Connection failed:
SQLState: '08001'
SQL Server Error: 17
[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied
==================

But it is OK when I use the front-end access database on the server PC.

What I can find out for now is the name of the server PC ("PC_NAME") is different from the network name ("NETWORK_NAME") that associated with the IP ("xxx.yyy.zz.vv") that the server PC is using through the network cable.

When I ping -a IP, I can see the name as NETWORK_NAME or ping NETWORK_NAME it will display the IP. But when I ping the PC_NAME, then it says not found.

when I do telnet NETWORKNAME/PC_NAME 1433, then It says:

X:\>telnet warehouse 1433
Connecting To warehouse...Could not open a connection to host on port 1433 : Con
nect failed

Does anyone know this can help me out? I will way thanks in advance.

Again, thank you for your reading it.

Charlie Tran

Reply With Quote