View Single Post
  #1 (permalink)  
Old January 17th, 2005, 05:00 AM
rodmcleay rodmcleay is offline
Friend of Wrox
Points: 2,376, Level: 20
Points: 2,376, Level: 20 Points: 2,376, Level: 20 Points: 2,376, Level: 20
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: , , Australia.
Posts: 596
Thanks: 1
Thanked 3 Times in 3 Posts
Default User COntrol Datagrid inside datagrid

Hi All,
I am having some trouble with a datagrid that is a user control when using it inside a datagrid.
Basically as part of the edit template I have included a user control that is a databound control.
In the ItemDatabound event I set the user controls "ResourceID" (Public Field in user control), and it loads up fine.
Then I click on an image button to edit the User control datagrid record and this loads up fine also showing the edit template as it should.
When I go to save the changes, the user control seems to lose track of the "ResourceID" I have assigned to it and defaults back to zero.
The update to the database then assigns the wrong ResourceID.

Any Assistance would be appreciated.




======================================
They say, best men are molded out of faults,
And, for the most, become much more the better
For being a little bad.
======================================
__________________
======================================
"They say, best men are molded out of faults,
And, for the most, become much more the better
For being a little bad."
--Shakespeare
======================================