View Single Post
  #1 (permalink)  
Old May 27th, 2011, 09:52 AM
aztech2403 aztech2403 is offline
Registered User
Points: 17, Level: 1
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSRS - Input string was not in a correct format

I am trying to hide rows in my report where a certain field is may be blank. I entered the following formula in the "Hidden" properties of the details row in layout:

=Iif(Fields!REVVAL3.Value="",TRUE,
Iif(Fields!REVVAL5.Value="",TRUE,
Iif(Fields!REVVAL6.Value="",TRUE,
Iif(Fields!REVVAL7.Value="",TRUE,
Iif(Fields!REVVAL8.Value="",TRUE,
Iif(Fields!REVVAL9.Value="",TRUE,
Iif(Fields!REVVAL10.Value="",TRUE,
Iif(Fields!REVVAL12.Value="",TRUE,
Iif(Fields!REVVAL14.Value="",TRUE,
Iif(Fields!REVVAL15.Value="",TRUE,FALSE))))))))))

I work for a hotel chain and the "REVVAL...value" represents a UserDefinedField at each property that contains the data I am trying to pull onto the report. In a perfect world, it would be easy if each property had the same UDF field defined for the same data, but that's not the case.

When I run the report, I get this error:
"An error occured during local report processing. The Hidden expression for the table 'table1' contains an error: Input string was not in a correct format.

Can anyone explain what I am doing wrong and what is the correct way to eliminate these rows when this field is blank?

Thank you.