View Single Post
 
Old March 27th, 2005, 05:16 PM
Seraphim Beshoner Seraphim Beshoner is offline
Registered User
 
Join Date: Mar 2005
Location: , , .
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default background image problems

I have a fixed background image underneath some links with attached images. As long as these linked images are not on top of the background they work fine but once they scroll on top of the image, the cursor only picks up the background image and no longer the linked images.

This is the css I have for the background image -

.background {
    /*This is the code for the transparent image on the index page. Position set to absolute for IE, later set to fixed for Firefox*/
    ;
    background-color: #ffffff;
    background-image: url(../Images/isidorescornerlg.jpg);
    background-repeat: no-repeat;
    background-position: left;
    opacity: 0.2;
    filter: alpha (opacity=20);
    position: absolute;
    width: 30%;
    height: 50%;
    top:20%;
    left:16%;
}

body>.maincontent>.background {
    position: fixed;
}

This is the css for the linked image-

.maincontent {
    width:80%;
    top:12%;
    left:18%;
    margin-left:18%;
    margin-top:12%;
    z-index:1;
}

.smimga {
    float: left;
    padding:1%;
    border:none;
}

And this is the html I'm using -
<div class="maincontent">
<div class="background"></div>[list]
  <li>
    <a href="../Isidores_Corner/BYS/BYS.html"><img
 class="smimga" alt="small button"
 src="../Isidores_Corner/Images/sbutton.gif" /></a>
  </li>
</ul>
</div>

Any suggestions?