View Single Post
  #1 (permalink)  
Old March 29th, 2005, 04:34 PM
Kristinn Kristinn is offline
Registered User
 
Join Date: Jan 2005
Location: , , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems calling ActiveX via localhost

I have not been able to run my WebService from the iis on my computer when trying to invoke the service via localhost as it does give an error when trying to call an ActiveX I’m using.

The code is ok when I run it from the Visual Web Developer 2005 Express Edition Beta.

The code is as follows:

CLService.asmx:
<%@ WebService Class="CLService" Language="vb" _ CodeBehind="~/Code/CLService2.vb" %>

CLService.vb:
Imports System.Web
Imports System.Web.Services
Imports System.Web.Services.Protocols

<WebService()> _
Public Class CLService
    Inherits System.Web.Services.WebService
    Dim myVLink As New VisualVoiceLink.VLink
    Dim sTemp As String

    <WebMethod()> _
    Public Function MyFunction(ByVal Var1 As String, _
 ByVal Var2 As String, ByVal Var3 As String) As String
        Try
            myVLink.Initialize()
            myVLink.Request("Server", "Subject", Var1, _
  Var2, Var3)
            If myVLink.ReceivedDataTotal > 0 Then
                Return CStr(myVLink.ReceivedData(0))
            Else
                Return "-1"
            End If
        Catch ex As Exception
            If ex.Message = "Could not find the VLink node _
               in the active node list."
            Then
                Return "Server not available!!!!"
            Else
                Return "Error in service: " & ex.Message
            End If
        End Try
    End Function
End Class

In the \bin subdirectory the Interop.VisualVoiceLink.dll is generated.

As I said earlier I can run this ok from the development environment and from a trace utility that came with the ActiveX I can see when it is loaded and the methods being called but when running this via localhost the ActiveX doesn’t appear to load in to memory due to something I can’t find out for my self.
I have installed the .NET framework 2.0 for the VWD 2005 EEB to work.

Is there anyone that can help me with this.

One desperate beginner.
Kristinn