View Single Post
  #1 (permalink)  
Old September 28th, 2011, 04:53 PM
jem18rc jem18rc is offline
Registered User
Points: 18, Level: 1
Points: 18, Level: 1 Points: 18, Level: 1 Points: 18, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2011
Location: MN USA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Get-CsSite, Provisioning An Application, Ch.7, P.176

Greetings! [updated #3] As outlined in Chapter 7 on Page 176:

The problem: Get-CsSite fails.

It fails within the Win7 Lync App Dev VM I have attached to the Lync 2010 Trial VHD Set (v.2011-06-09).

Questions and Observations:

Steps taken thus far to connect app dev vm to Lync VHD Set: Added the app dev vm to the Fabrikam domain and I hard coded the IPv4 properties for IP Address in the Lync 2010 Trial VHD Set range (192.168.0.51), and set the DNS server to point to Lync DC (192.168.0.18).
Are there further steps necessary to wire the App Dev VM users to AD and/or security groups?
Help for Get-CsSite specifies "By default, members of the following groups are authorized to run the Get-CsSite cmdlet locally..." (http://technet.microsoft.com/en-us/l.../gg398185.aspx)
I am logging in with (Lync-DevA\Administrator). Is it better to create another user to login with?
In the DC I can see the Lync-DevA app dev vm, and I can see how to add the *computer* to a DC security group, however I am not clear on how to add a Lync-DevA user to a DC wide security group
Is the problem that I am running Win7 and not Server 2008 as an app dev vm?
What is a good resource on the subject of adding a Lync app dev machine to the Lync network? For example do I need to follow the steps outlined here: http://lyncinsider.com/conferencing/...tor-must-know/

Lync client, and WPF presence controls work great from app dev vm

also only DC, Lync-SE and app dev machine are actually started (no need for sharepoint, exum and QMS at this point right?)

The background:

HMy goal is to acquire the dev app server endpoint to test the Hello World Sample in the Unified Communications Managed API 3.0 Workflow SDK.

The solution has been converted and runs the dev app server: a Win 7 virtual which is part of the Fabrikam domain for the Lync Trial VHD Set (v.2011-06-09).

My understanding is that there is a number of steps that lead up to creating a trusted app pool via powershell, however I did add the win 7 dev app server as a trusted app server through the Server (Lync-SE) topology builder.

However it concerns me that the Get-CsSite powershell command doesn't execute correctly. This seems to be the first step if I follow the steps from another related post:

(I have also ran the core SDK bootstrapper, which was also mentioned in another post. Although I'm not clear that I needed to do that, or where that would be found in the SDK help instructions...)

Here is my experience:

PS C:\Users\Administrator> Get-CsSite

Get-CsSite : Active Directory operation failed on "dc.fabrikam.com". The credential supplied for "LYNC-DevA\Administrator" on "Bind" operation is invalid. Error Code: "49".

At line:1 char:11

+ Get-CsSite <<<<

+ CategoryInfo : NotSpecified: (:) [Get-CsSite], ADInvalidCredentialException

+ FullyQualifiedErrorId : Microsoft.Rtc.Management.ADConnect.ADInvalidCreden tialException,Microsoft.Rtc.Management.Xds.GetSite Cmdlet

PS C:\Users\Administrator> ping dc.fabrikam.com

....

Ping statistics for 192.168.0.18:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Last edited by jem18rc; September 29th, 2011 at 10:18 AM.. Reason: Greater clarity
Reply With Quote