View Single Post
  #1 (permalink)  
Old May 24th, 2005, 03:43 PM
itsajourney itsajourney is offline
Registered User
 
Join Date: May 2005
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help, trying to fill grid w/database items

Hi everyone, I am new

(Visual Basic) I am having a problem loading data into data grid on my form in Visual Studio from an Access db. Here is the line of code:

   Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        DsStudent1.Clear()
        OleDbDataAdapter1.Fill(DsStudent1)

When I try to run it I get:

 An unhandled exception of type 'system.Data.OleDb.OleDbException
occured in system.data.dll

That last line of code is highlighted in debug mode

I've got my connection, adapter, and dataset.i have tested my connection and it works. I have set the data source and data members correctly to my ds. When I go to Preview Data, then click fill data set, it works fine. Just won't load to form. Tried using a button instead but still nothing. I am pretty positive that my steps to connect are right.

I am using the Jet 4.0 provider as directed by my teacher. Could it have something to do with the MSDE? I can't so much locate it on my machine. I thought I had it but after looking, couldn't find it, so I downloaded it from microsoft. But still no luck. I bet it is something easy, but I have spent sooooo many hours trying to figure it out

Quick replies are so very much appreciated. Thanks sooooooooooo much

~C


Reply With Quote