View Single Post
  #3 (permalink)  
Old August 25th, 2014, 12:17 AM
JeffPalley JeffPalley is offline
Registered User
Points: 33, Level: 1
Points: 33, Level: 1 Points: 33, Level: 1 Points: 33, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Yup, I posted the aspx.vb file twice and no aspx. Sorry.

Hi again Imar,

There goes my credibility! Well, I guess it comes from staring at the code too long. So here goes again. Starting with Containers.aspx:

Code:

Partial Class Containers
  Inherits System.Web.UI.Page

  Protected Sub CheckBox1_CheckedChanged(sender As Object, e As System.EventArgs) Handles CheckBox1.CheckedChanged
    Panel1.Visible = True
  End Sub

End Class
You'll notice that I changed the Boolean "Checkbox1.CheckedChanged" to its boiled-down equivalent: "True". Just an attempt to avoid anything that might be behind the problem, and I may have made similar tiny changes in other places. However, in both the standard ("in-your-book) version and in the boiled-down version, that Sub appears to have run, although ineffectively. Also, without thinking I named everything "Container" in the beginning and not "Containers." I changed back to "Containers," but there may be some hidden detritus from the renames that's currently inaccessible to me, given the state of my ignorance about ASP.NET.

Here (again) is the code for Containers.aspx.vb"

Code:

Partial Class Containers
  Inherits System.Web.UI.Page

  Protected Sub CheckBox1_CheckedChanged(sender As Object, e As System.EventArgs) Handles CheckBox1.CheckedChanged
    Panel1.Visible = True
  End Sub

End Class
I very much appreciate your patience (I didn't used to be a moron), and thanks again,

-Jeff Palley
JeffPalley@gmail.com

P.S. If it helps, I just noticed that if I make the default browser Chrome instead of IE, I get a little bit more when I check the checkbox ("I am visible now" appears, but the panel is still not visible).

Last edited by JeffPalley; August 25th, 2014 at 12:21 AM.. Reason: error in post
Reply With Quote