View Single Post
  #1 (permalink)  
Old October 31st, 2006, 11:13 AM
riki_gill riki_gill is offline
Authorized User
 
Join Date: Oct 2006
Location: , , .
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Get an error when creating new user...??...Urgent

I am getting the following error when I try to create a new user using Visual developer 2005: I already have admin & the users roles created.

The following message may help in diagnosing the problem: Exception has been thrown by the target of an invocation. at System.RuntimeMethodHandle._InvokeMethodFast(Objec t target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner) at System.RuntimeMethodHandle.InvokeMethodFast(Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at System.Web.Administration.WebAdminMembershipProvid er.CallWebAdminMembershipProviderHelperMethodOutPa rams(String methodName, Object[] parameters, Type[] paramTypes) at System.Web.Administration.WebAdminMembershipProvid er.CreateUser(String username, String password, String email, String passwordQuestion, String passwordAnswer, Boolean isApproved, Object providerUserKey, MembershipCreateStatus& status) at System.Web.UI.WebControls.CreateUserWizard.Attempt CreateUser() at System.Web.UI.WebControls.CreateUserWizard.OnNextB uttonClick(WizardNavigationEventArgs e) at System.Web.UI.WebControls.Wizard.OnBubbleEvent(Obj ect source, EventArgs e) at System.Web.UI.WebControls.CreateUserWizard.OnBubbl eEvent(Object source, EventArgs e) at System.Web.UI.WebControls.Wizard.WizardChildTable. OnBubbleEvent(Object source, EventArgs args) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.Button.OnCommand(Command EventArgs e) at System.Web.UI.WebControls.Button.RaisePostBackEven t(String eventArgument) at System.Web.UI.WebControls.Button.System.Web.UI.IPo stBackEventHandler.RaisePostBackEvent(String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(IPostBackEve ntHandler sourceControl, String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(NameValueCol lection postData) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


I also noticed that in the machine.config file the following:
<configProtectedData defaultProvider="RsaProtectedConfigurationProvider ">

      <providers>

            <add name="RsaProtectedConfigurationProvider"

type="System.Configuration.RsaProtectedConfigurati onProvider,System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"

[u]description</u>="Uses RsaCryptoServiceProvider to encrypt and decrypt"

            [u]keyContainerName</u>="NetFrameworkConfigurationKey"

            [u]cspProviderName</u>=""

            [u]useMachineContainer</u>="true"

            [u]useOAEP</u>="false" />



            <add name="DataProtectionConfigurationProvider"

type="System.Configuration.DpapiProtectedConfigura tionProvider,System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"

description="Uses CryptProtectData and CryptUnProtectData Windows APIs to encrypt and decrypt"

            useMachineProtection="true"

            keyEntropy="" />

      </providers>

</configProtectedData>

All the underlined attributes says not declared.

Note: When we use the login tools the table and database is auto generated for u but I changed it to my database that I created in MS SQL server 2000.

After changing the connection string from default (auto generated), I noticed the line saying attribute not declared.

I have been stuck on this for the last week…So could you help me…thanks…appreciate it!