View Single Post
  #1 (permalink)  
Old November 9th, 2006, 03:49 AM
cancer10 cancer10 is offline
Authorized User
 
Join Date: Oct 2006
Location: New Delhi, Delhi, India.
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sending HTML Mailer With SWF

Hi,

I am trying to send the following HTML mail thru the ASP CDO component.

This is the HTML mail i wanna send from Page 1:
Code:
<div align="center">
  <table width="100%" border="0" cellspacing="0" cellpadding="0">
    <tr>
      <td><div align="center">
          <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="820" height="540">
            <param name="movie" value="http://mywebsite.com/movie1.swf">
            <param name="quality" value="high">
            <embed src="http://mywebsite.com/movie1.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="820" height="540"></embed></object>
        </div></td>
    </tr>
  </table>
</div>

This the the code of the second page which sends the mail.
Code:
<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.HTMLBody = request.form("txtmessage") 
myMail.Send
set myMail=nothing
%>


My mail contains absolute path of the the SWF file, but the problem is when I receive the mail (tested with Gmail, yahoomail etc) I get a blank email with absolutely nothing in it.

I have tested the mail with only HTML hyperlinks and it works but not with an embedd SWF file :(


Any idea how to make it work?


Thanx

-----------------------------------------------
www.chargertek.in - Cheapest WebHosting
__________________
-----------------------------------------------
www.chargertek.in - Cheapest WebHosting