View Single Post
  #3 (permalink)  
Old September 7th, 2003, 01:08 PM
drfunkie drfunkie is offline
Authorized User
 
Join Date: Jun 2003
Location: New orleans, Louisiana, USA.
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You are right IMAR, the form tags are missing from the code on the subscribe.aspx page.

The form seems to be an oversight by the developers of the book. The tags are missing in both the C# version and the VB Versions of the code.

Here is my subscribe.aspx page with the form tags.

<%@ Register
    TagPrefix="WroxUser" TagName="SiteHeader"
    Src="/ThePhileVB/Controls/User/SiteHeader.ascx"
%>
<%@ Register
    TagPrefix="WroxUser" TagName="SiteFooter"
    Src="/ThePhileVB/Controls/User/SiteFooter.ascx"
%>
<%@ Register
    TagPrefix="Wrox"
    Namespace="Wrox.ThePhile.Web.Controls.Server"
    Assembly="Wrox.ThePhile"
%>
<%@ Page
    language="vb"
    Codebehind="Subscribe.aspx.vb"
    AutoEventWireup="false"
    Inherits="Wrox.WebModules.MailingLists.Web.Subscri be"
%>
<!doctype html public "-//w3c//dtd html 4.0 transitional//en" >
<html>
    <head>
        <title>MailingLists: Subscription</title>
        <meta name="code_language" content="Visual Basic 7.0">
        <link rel="stylesheet" href="../../Styles/ThePhile.css" />
        <link rel="stylesheet" href="../../Styles/Navigator.css" />
    </head>
    <body>
    <form id="subscribe" runat="server" method="post">
        <WroxUser:SiteHeader id="Header" runat="server" />
        <br/>
        <table width="100%" border="0" cellspacing="4" cellpadding="2">
            <tr>
                <td width="100%" valign="top">
                    <asp:Label id="Subject" runat="Server"
                        CssClass="SubscrSubject"
                        Visible="false" />
                    <br/>
                    <asp:Label id="Message" runat="Server"
                        CssClass="SubscrMessage"
                        Visible="false" />
                    <asp:Label id="EmailRequired" runat="server"
                        Text="The Email address is required"
                        Visible="false"
                        CssClass="Error" />
                </td>
                <td align="right" valign="top">
                    <Wrox:Navigator id="MenuNav" runat="server"
                        SourceFile="/ThePhileVB/Config/NavMenu.xml"
                        TransformFile="/ThePhileVB/Styles/NavMenu.xslt" />
                </td>
            </tr>
        </table>
        <WroxUser:SiteFooter id="Footer" runat="server" />
        </form> </body>
</html>[/blue

The page is working now but the Link to [blue]unsubscribe is not working, however this is a peace of cake to fix.

Thanks again IMAR