View Single Post
  #1 (permalink)  
Old February 5th, 2004, 11:32 AM
Greywacke Greywacke is offline
Authorized User
 
Join Date: Sep 2003
Location: Wonderboom South, Pretoria, Gauteng, South Africa.
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Greywacke
Default JET Panic :/ what is wrong???

Error Type:
Microsoft JET Database Engine (0x80040E10)
No value given for one or more required parameters.
/rpgcasino/scripts/functions.asp, line 63

Code:
With Response
    If gwPag = "0" Or gwPag = "1" Or gwPag = "5" Or gwPag = "6" Then
        .Write "var f = new Array();" & vbCrLf
        .Write "function selcountry() {" & vbCrLf
        .Write "    i = document.frm_racc.racc_country.selectedIndex;" & vbCrLf
        .Write "    document.images['flag'].src = 'iface/flags/' + i + '.gif';" & vbCrLf
        .Write "    loadstates(i);" & vbCrLf
        .Write "}" & vbCrLf
        .Write "var p = new Array();" & vbCrLf
        .Write "p[0] = '<-- No states/provinces available -->';" & vbCrLf
        Set gwRS = Server.CreateObject("ADODB.Recordset")
        Set gwRS1 = Server.CreateObject("ADODB.Recordset")
        SQLStr = "SELECT * FROM countries ORDER BY str_name ASC"
        gwRS.Open SQLStr, gwConn, adOpenDynamic, adLockOptimistic, adCmdText
        i = 1
        Do While Not gwRS.EOF
            .Write "p[" & i & "] = '"
            cid = gwRS("lng_id")
            SQLStr = "SELECT str_name FROM states WHERE lng_countryid = " & cid & " ORDER BY str_name ASC"
            gwRS1.Open SQLStr, gwConn, adOpenDynamic, adLockOptimistic, adCmdText ' line 63
            Do While Not gwRS1.EOF
                .Write Replace(gwRS1("str_name"),"'","\'") & ", "
                gwRS1.MoveNext
            Loop
            .Write "';" & vbCrLf
            gwRS1.Close
            i = i + 1
            gwRS.MoveNext
        Loop
        gwRS.Close
    ' more If statements for the other cases of gwpag
    End If
End With
basically what the hell is up with that? i am kinda starting to panic here... the adodb constants library is included in the global.asa, and the connection is set to Application("gwConn") at start of page... other scripts work perfectly, it's just this one which implicates that gwRS("lng_id") is returning a blank string, while in actual fact it is returning the country id (long number)???

any swift help to resolve this issue will be greatly appreciated...

Sincerely,
Pierre du Toit.
__________________
Sincerely,
Pierre "Greywacke" du Toit
pierre@greywacke.co.za
don't worry about my 0 thankyou's either way, i would say thank you should you help, and i will gladly help others when this work rush is over.
Reply With Quote