p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

activex_data_objects thread: Problem disconnecting recordset


Message #1 by "Ian" <ian_cox2001@h...> on Fri, 2 Nov 2001 11:34:31
Hi all! I'm new to this list so here goes my first query.

I have a VB function that returns a disconnected recordset, it does this 

by creating an ADO command object populated with some parameters and a 

stored procedure, I set the source property of an ADO recordset to this 

command object. I then open the recordset, set the activeconnection to 

nothing and close the connection.

This works fine...

Until, I change to using a DSN-less connection (which is what I want to 

use). Then I get this error

"Cannot change the active connection property of a recordset which has a 

command object as its source."

Is there anyway around this?

I want to use a command object because I want to send in a number of 

parameters and I want to check a couple of them for return values.





Thanks in advance for any help

Cheers

Ian
Message #2 by Nick Parker <nparker@i...> on Fri, 2 Nov 2001 09:30:44 -0600 (CST)
Dear Ian,

  

   I just want to make some assumptions first.  You are supplying a ADO 

connection string now before making any request correct?

 

   Nick



> Hi all! I'm new to this list so here goes my first query.

> I have a VB function that returns a disconnected recordset, it does this 

> by creating an ADO command object populated with some parameters and a 

> stored procedure, I set the source property of an ADO recordset to this 

> command object. I then open the recordset, set the activeconnection to 

> nothing and close the connection.

> This works fine...

> Until, I change to using a DSN-less connection (which is what I want to 

> use). Then I get this error

> "Cannot change the active connection property of a recordset which has a 

> command object as its source."

> Is there anyway around this?

> I want to use a command object because I want to send in a number of 

> parameters and I want to check a couple of them for return values.

> 

> 

> Thanks in advance for any help

> Cheers

> Ian

> 




$subst('Email.Unsub')

> 










  Return to Index