p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

asp_components thread: Component debugging????????????


Message #1 by "Nguyen Anh Tuan" <tuancan@y...> on Wed, 22 May 2002 18:11:09
I debug it from ASP.

Private objContext As COMSVCSLib.ObjectContext

Private objRequest As ASPTypeLibrary.Request
Private objResponse As ASPTypeLibrary.Response

Private Sub Class_Initialize()
    Set objContext = GetObjectContext()

    Set objRequest = objContext("Request") 	<-- It shows "Run-time 
error '424' Object required" error at this line

    Set objResponse = objContext("Response")
End Sub
Message #2 by "Nguyen Anh Tuan" <tuancan@y...> on Thu, 23 May 2002 04:51:07
I write a ASP component in which i use references to COM+ Service Type 
Library and Microsoft Active Server Pages Objects Library. It runs well. 
But when i try to debug it from ASP throught VB component, it shows me an 
error "Runtime error '424' Object required". Why?

ASP Code:

<%@ Language=VBScript %>
<html>
<head>
</head>
<body>

<%
	Set myGrid = Server.CreateObject("myGrid.TextOnly")
	
	Call myGrid.Generate()
%>

</body>
</html>

VB Code:

Private objContext As COMSVCSLib.ObjectContext

Private objRequest As ASPTypeLibrary.Request
Private objResponse As ASPTypeLibrary.Response

Private Sub Class_Initialize()
    Set objContext = GetObjectContext()
    
    Set objRequest = objContext("Request") 	<-- Error at this line
    Set objResponse = objContext("Response")
End Sub

  Return to Index