p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

asp_databases thread: unspecified error


Message #1 by "Nick" <nikosdra@l...> on Tue, 25 Jun 2002 13:05:56
Hello all,

I have a select statement in my asp page and when i execute it i receive 
an "(0x80004005) Unspecified error" message. What's strange to me is 
that, when i remove a column from the select statement, the query runs 
smoothly and no error appears. This column is a text(1) datatype in an 
Access database, which i use to store 2 boolean values: "y" an "n". But i 
is just plain text column.

Can anybody help me on this??

Thanks in advance

Nick
Message #2 by "Chirag Shah" <chiragiit@y...> on Fri, 7 Jun 2002 19:45:44
what's your connection string looks like..?



> I'm having a strange problem with my website. I get this error message, 
M> icrosoft OLE DB Provider for ODBC Drivers 
e> rror '80004005' Unspecified Error , on my website sometimes when 
c> onnectiong to an Oracle database. I use Microsoft ODBC driver for 
Oracle 
t> o connect to the DB. The error message happens intermittently and when 
I 
r> eboot the server it goes away. Server is NT4.0/IIS4.0. 
 > 
D> on't have any idea what's going on. Any clue to this problem???? 
Message #3 by "Joseph Santhosh" <sjoseph@m...> on Fri, 7 Jun 2002 18:17:39
I'm having a strange problem with my website. I get this error message, 
Microsoft OLE DB Provider for ODBC Drivers 
error '80004005' Unspecified Error , on my website sometimes when 
connectiong to an Oracle database. I use Microsoft ODBC driver for Oracle 
to connect to the DB. The error message happens intermittently and when I 
reboot the server it goes away. Server is NT4.0/IIS4.0. 
 
Don't have any idea what's going on. Any clue to this problem???? 
Message #4 by "Ken Schaefer" <ken@a...> on Wed, 26 Jun 2002 11:36:53 +1000
www.adopenstatic.com/faq/80040e14.asp
(look at Scenario 2 - Syntax Error in INSERT INTO statement)

Cheers
Ken

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
From: "Nick" <nikosdra@l...>
Subject: [asp_databases] RE: unspecified error


: OK, here's the INSERT statement (it's the same problem, and it's primary
: since i use it before the select):
:
: sql = "insert into seasons (site_id, name, stype_id,
: current) values (" & Session("Site") & ", '" & name  & "', '" & stype
: & "', '" & current & "') ;"
:
: The problem appears with the last "current" field. I describe the current
: variable as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Message #5 by "Mark Anderson" <marke.anderson@b...> on Tue, 25 Jun 2002 15:55:47 +0100
Is the field a reserved word? Copy the query into the access create query
window and substitute values for your variables and then try running it.  If
you still get the error replace the field name with something like current1
or anything to change it from being a reserved word, and then try.

Mark

-----Original Message-----
From: Nick [mailto:nikosdra@l...]
Sent: 25 June 2002 15:54
To: ASP Databases
Subject: [asp_databases] RE: unspecified error


OK, here's the INSERT statement (it's the same problem, and it's primary
since i use it before the select):

		sql = "insert into seasons (site_id, name, stype_id,
current) values (" & Session("Site") & ", '" & name  & "', '" & stype
& "', '" & current & "') ;"

The problem appears with the last "current" field. I describe the current
variable as follows:

if request.form("current") = "y" then
	current = "y"
else
	current = "n"
end if

The error message:
Technical Information (for support personnel)

Error Type:
Microsoft JET Database Engine (0x80040E14)
Syntax error in INSERT INTO statement.
/eteams/admin/add_season.asp, line 56


 When i do not execute the code and print my query i see:
insert into seasons (site_id, name, stype_id, current) values
(95, 'onomatis', 'FA', 'y');

......which, when i insert it in an Access view, it is appended
smoothly....

Nick






> Nick,

I think what he meant is "Why don't you show us some code".  It's hard to
debug your SELECT statement if we don't know what it looks like.  I
suspect
that you have a field named with a reserved keyword, but who knows unless
you post your code.

Pete


> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 1:47 PM
> To: ASP Databases
> Subject: [asp_databases] RE: unspecified error
>
>
> Running a query to look at, IS a solution (i have made it
> work). BUT i
> have too many select statements across my application and i
> dont want to
> fill my Access db with so many queries. I would prefer to
> find and solve
> the root of the problem....
>
> Nick
>
> > How about a query to look at?
>
> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 8:06 AM
> To: ASP Databases
> Subject: [asp_databases] unspecified error
>
>
> Hello all,
>
> I have a select statement in my asp page and when i execute
> it i receive
> an "(0x80004005) Unspecified error" message. What's strange to me is
> that, when i remove a column from the select statement, the
> query runs
> smoothly and no error appears. This column is a text(1)
> datatype in an
> Access database, which i use to store 2 boolean values: "y"
> an "n". But i
> is just plain text column.
>
> Can anybody help me on this??
>
> Thanks in advance
>
> Nick
>

Message #6 by "Roy, Siddarth S" <sroy@b...> on Tue, 25 Jun 2002 10:49:04 -0400
Sorry Wrong answer


-----Original Message-----
From: Roy, Siddarth S
Sent: Tuesday, June 25, 2002 10:46 AM
To: ASP Databases
Subject: [asp_databases] RE: unspecified error


Did U check the permissions of the user
i dont know throughly abt it please do check  permissions of the user in 
the system with access in use

thx
sid
-----Original Message-----
From: Nick [mailto:nikosdra@l...]
Sent: Tuesday, June 25, 2002 11:54 AM
To: ASP Databases
Subject: [asp_databases] RE: unspecified error


OK, here's the INSERT statement (it's the same problem, and it's primary 

since i use it before the select):

		sql =3D "insert into seasons (site_id, name, stype_id,
current) values (" & Session("Site") & ", '" & name  & "', '" & stype 
& "', '" & current & "') ;"

The problem appears with the last "current" field. I describe the 
current
variable as follows:

if request.form("current") =3D "y" then
	current =3D "y"
else
	current =3D "n"
end if

The error message:
Technical Information (for support personnel)

Error Type:
Microsoft JET Database Engine (0x80040E14)
Syntax error in INSERT INTO statement.
/eteams/admin/add_season.asp, line 56


 When i do not execute the code and print my query i see:
insert into seasons (site_id, name, stype_id, current) values
(95, 'onomatis', 'FA', 'y');

......which, when i insert it in an Access view, it is appended
smoothly....

Nick






> Nick,

I think what he meant is "Why don't you show us some code".  It's hard 
to
debug your SELECT statement if we don't know what it looks like.  I
suspect
that you have a field named with a reserved keyword, but who knows 
unless
you post your code.

Pete


> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 1:47 PM
> To: ASP Databases
> Subject: [asp_databases] RE: unspecified error
>
>
> Running a query to look at, IS a solution (i have made it
> work). BUT i
> have too many select statements across my application and i
> dont want to
> fill my Access db with so many queries. I would prefer to
> find and solve
> the root of the problem....
>
> Nick
>
> > How about a query to look at?
>
> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 8:06 AM
> To: ASP Databases
> Subject: [asp_databases] unspecified error
>
>
> Hello all,
>
> I have a select statement in my asp page and when i execute
> it i receive
> an "(0x80004005) Unspecified error" message. What's strange to me is
> that, when i remove a column from the select statement, the
> query runs
> smoothly and no error appears. This column is a text(1)
> datatype in an
> Access database, which i use to store 2 boolean values: "y"
> an "n". But i
> is just plain text column.
>
> Can anybody help me on this??
>
> Thanks in advance
>
> Nick
>

Message #7 by "Roy, Siddarth S" <sroy@b...> on Tue, 25 Jun 2002 10:46:28 -0400
Did U check the permissions of the user
i dont know throughly abt it please do check  permissions of the user in 
the system with access in use

thx
sid
-----Original Message-----
From: Nick [mailto:nikosdra@l...]
Sent: Tuesday, June 25, 2002 11:54 AM
To: ASP Databases
Subject: [asp_databases] RE: unspecified error


OK, here's the INSERT statement (it's the same problem, and it's primary 

since i use it before the select):

		sql =3D "insert into seasons (site_id, name, stype_id,
current) values (" & Session("Site") & ", '" & name  & "', '" & stype 
& "', '" & current & "') ;"

The problem appears with the last "current" field. I describe the 
current
variable as follows:

if request.form("current") =3D "y" then
	current =3D "y"
else
	current =3D "n"
end if

The error message:
Technical Information (for support personnel)

Error Type:
Microsoft JET Database Engine (0x80040E14)
Syntax error in INSERT INTO statement.
/eteams/admin/add_season.asp, line 56


 When i do not execute the code and print my query i see:
insert into seasons (site_id, name, stype_id, current) values
(95, 'onomatis', 'FA', 'y');

......which, when i insert it in an Access view, it is appended
smoothly....

Nick






> Nick,

I think what he meant is "Why don't you show us some code".  It's hard 
to
debug your SELECT statement if we don't know what it looks like.  I
suspect
that you have a field named with a reserved keyword, but who knows 
unless
you post your code.

Pete


> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 1:47 PM
> To: ASP Databases
> Subject: [asp_databases] RE: unspecified error
>
>
> Running a query to look at, IS a solution (i have made it
> work). BUT i
> have too many select statements across my application and i
> dont want to
> fill my Access db with so many queries. I would prefer to
> find and solve
> the root of the problem....
>
> Nick
>
> > How about a query to look at?
>
> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 8:06 AM
> To: ASP Databases
> Subject: [asp_databases] unspecified error
>
>
> Hello all,
>
> I have a select statement in my asp page and when i execute
> it i receive
> an "(0x80004005) Unspecified error" message. What's strange to me is
> that, when i remove a column from the select statement, the
> query runs
> smoothly and no error appears. This column is a text(1)
> datatype in an
> Access database, which i use to store 2 boolean values: "y"
> an "n". But i
> is just plain text column.
>
> Can anybody help me on this??
>
> Thanks in advance
>
> Nick
>
Message #8 by "Nick" <nikosdra@l...> on Tue, 25 Jun 2002 15:00:27
Although my question concerned a select statement, i do exactly what you 
advise in another insert statement, and i receive an error again (Syntax 
error in UPDATE statement). Again, when i remove that (text(1)) field 
from the insert statement, everything works fine....

Nick

Just add the following code somewhere:

if [boolean]=true then
   strAnswer = "Y"
else
   strAnswer = "N"
end if

after this you could run the insert sql statement. Using the string 
instead of
the booleans.

Greatings Dennis

> Hello all,
> 
> I have a select statement in my asp page and when i execute it i 
receive 
> an "(0x80004005) Unspecified error" message. What's strange to me is 
> that, when i remove a column from the select statement, the query runs 
> smoothly and no error appears. This column is a text(1) datatype in an 
> Access database, which i use to store 2 boolean values: "y" an "n". But 
i 
> is just plain text column.
> 
> Can anybody help me on this??
> 
> Thanks in advance
> 
> Nick
> 
> 



Message #9 by Emily Minier <eminier@d...> on Tue, 25 Jun 2002 08:48:57 -0500
Will you please provide the select statement so that I may examine it.
Please provide the version with which you are receiving the error.

Emily Minier
Technical Coordinator
Dollar Rent A Car Systems, Inc
(xxx) xxx-xxxx


-----Original Message-----
From: Nick [mailto:nikosdra@l...]
Sent: Tuesday, June 25, 2002 10:00 AM
To: ASP Databases
Subject: [asp_databases] Re: unspecified error


Although my question concerned a select statement, i do exactly what you 
advise in another insert statement, and i receive an error again (Syntax 
error in UPDATE statement). Again, when i remove that (text(1)) field 
from the insert statement, everything works fine....

Nick

Just add the following code somewhere:

if [boolean]=true then
   strAnswer = "Y"
else
   strAnswer = "N"
end if

after this you could run the insert sql statement. Using the string 
instead of
the booleans.

Greatings Dennis

> Hello all,
> 
> I have a select statement in my asp page and when i execute it i 
receive 
> an "(0x80004005) Unspecified error" message. What's strange to me is 
> that, when i remove a column from the select statement, the query runs 
> smoothly and no error appears. This column is a text(1) datatype in an 
> Access database, which i use to store 2 boolean values: "y" an "n". But 
i 
> is just plain text column.
> 
> Can anybody help me on this??
> 
> Thanks in advance
> 
> Nick
> 
> 



Message #10 by "Peter Foti (PeterF)" <PeterF@S...> on Tue, 25 Jun 2002 10:01:15 -0400
Nick,

I think what he meant is "Why don't you show us some code".  It's hard to
debug your SELECT statement if we don't know what it looks like.  I suspect
that you have a field named with a reserved keyword, but who knows unless
you post your code.

Pete


> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 1:47 PM
> To: ASP Databases
> Subject: [asp_databases] RE: unspecified error
> 
> 
> Running a query to look at, IS a solution (i have made it 
> work). BUT i 
> have too many select statements across my application and i 
> dont want to 
> fill my Access db with so many queries. I would prefer to 
> find and solve 
> the root of the problem....
> 
> Nick
> 
> > How about a query to look at?
> 
> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 8:06 AM
> To: ASP Databases
> Subject: [asp_databases] unspecified error
> 
> 
> Hello all,
> 
> I have a select statement in my asp page and when i execute 
> it i receive 
> an "(0x80004005) Unspecified error" message. What's strange to me is 
> that, when i remove a column from the select statement, the 
> query runs 
> smoothly and no error appears. This column is a text(1) 
> datatype in an 
> Access database, which i use to store 2 boolean values: "y" 
> an "n". But i 
> is just plain text column.
> 
> Can anybody help me on this??
> 
> Thanks in advance
> 
> Nick
> 
Message #11 by "Nick" <nikosdra@l...> on Tue, 25 Jun 2002 13:47:25
Running a query to look at, IS a solution (i have made it work). BUT i 
have too many select statements across my application and i dont want to 
fill my Access db with so many queries. I would prefer to find and solve 
the root of the problem....

Nick

> How about a query to look at?

-----Original Message-----
From: Nick [mailto:nikosdra@l...]
Sent: Tuesday, June 25, 2002 8:06 AM
To: ASP Databases
Subject: [asp_databases] unspecified error


Hello all,

I have a select statement in my asp page and when i execute it i receive 
an "(0x80004005) Unspecified error" message. What's strange to me is 
that, when i remove a column from the select statement, the query runs 
smoothly and no error appears. This column is a text(1) datatype in an 
Access database, which i use to store 2 boolean values: "y" an "n". But i 
is just plain text column.

Can anybody help me on this??

Thanks in advance

Nick
Message #12 by "Meinken, Joe" <Joe.Meinken@q...> on Tue, 25 Jun 2002 07:17:44 -0500
How about a query to look at?

-----Original Message-----
From: Nick [mailto:nikosdra@l...]
Sent: Tuesday, June 25, 2002 8:06 AM
To: ASP Databases
Subject: [asp_databases] unspecified error


Hello all,

I have a select statement in my asp page and when i execute it i receive 
an "(0x80004005) Unspecified error" message. What's strange to me is 
that, when i remove a column from the select statement, the query runs 
smoothly and no error appears. This column is a text(1) datatype in an 
Access database, which i use to store 2 boolean values: "y" an "n". But i 
is just plain text column.

Can anybody help me on this??

Thanks in advance

Nick
Message #13 by d.van.herk@w... on Tue, 25 Jun 2002 14:18:56 +0200
Maybe it's not the easiest way, but I think it would help.

Just add the following code somewhere:

if [boolean]=true then
   strAnswer = "Y"
else
   strAnswer = "N"
end if

after this you could run the insert sql statement. Using the string instead of
the booleans.

Greatings Dennis

> Hello all,
> 
> I have a select statement in my asp page and when i execute it i receive 
> an "(0x80004005) Unspecified error" message. What's strange to me is 
> that, when i remove a column from the select statement, the query runs 
> smoothly and no error appears. This column is a text(1) datatype in an 
> Access database, which i use to store 2 boolean values: "y" an "n". But i 
> is just plain text column.
> 
> Can anybody help me on this??
> 
> Thanks in advance
> 
> Nick
> 
> 



Message #14 by "Nick" <nikosdra@l...> on Tue, 25 Jun 2002 15:54:26
OK, here's the INSERT statement (it's the same problem, and it's primary 
since i use it before the select):

		sql = "insert into seasons (site_id, name, stype_id, 
current) values (" & Session("Site") & ", '" & name  & "', '" & stype  
& "', '" & current & "') ;"

The problem appears with the last "current" field. I describe the current 
variable as follows:

if request.form("current") = "y" then
	current = "y"
else
	current = "n"
end if

The error message:
Technical Information (for support personnel)

Error Type:
Microsoft JET Database Engine (0x80040E14)
Syntax error in INSERT INTO statement.
/eteams/admin/add_season.asp, line 56


 When i do not execute the code and print my query i see:
insert into seasons (site_id, name, stype_id, current) values 
(95, 'onomatis', 'FA', 'y');

......which, when i insert it in an Access view, it is appended 
smoothly....

Nick






> Nick,

I think what he meant is "Why don't you show us some code".  It's hard to
debug your SELECT statement if we don't know what it looks like.  I 
suspect
that you have a field named with a reserved keyword, but who knows unless
you post your code.

Pete


> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 1:47 PM
> To: ASP Databases
> Subject: [asp_databases] RE: unspecified error
> 
> 
> Running a query to look at, IS a solution (i have made it 
> work). BUT i 
> have too many select statements across my application and i 
> dont want to 
> fill my Access db with so many queries. I would prefer to 
> find and solve 
> the root of the problem....
> 
> Nick
> 
> > How about a query to look at?
> 
> -----Original Message-----
> From: Nick [mailto:nikosdra@l...]
> Sent: Tuesday, June 25, 2002 8:06 AM
> To: ASP Databases
> Subject: [asp_databases] unspecified error
> 
> 
> Hello all,
> 
> I have a select statement in my asp page and when i execute 
> it i receive 
> an "(0x80004005) Unspecified error" message. What's strange to me is 
> that, when i remove a column from the select statement, the 
> query runs 
> smoothly and no error appears. This column is a text(1) 
> datatype in an 
> Access database, which i use to store 2 boolean values: "y" 
> an "n". But i 
> is just plain text column.
> 
> Can anybody help me on this??
> 
> Thanks in advance
> 
> Nick
> 

  Return to Index