p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

crystal_reports thread: Error File Not Found


Message #1 by "Tony Cooper" <tony.cooper@h...> on Fri, 7 Jun 2002 11:54:15
Hi All,

I know there are many postings about this particular error. And believe me 
I've tried them all. Here goes....
VB6 and Crystal 8.5 reports...
Works fine of dev m/c, however on client pc when you request a report we 
get Error "table" not found at location....

Before you all write back... I have included the file p2*.dll in the 
installation.

My setup is dev m/c with XP prof. VB6 sp5. Visual studio Installer 1.1 to 
create the .msi file.
Client PC is Clean install of Win98 SE.

I'm really stuck and time is runnning out to get this working. Has anybody 
got any new ideas? I'd really appreciate it..

Thanks

Tony
Message #2 by "Wong Tze Lun" <tzelun0502@l...> on Fri, 07 Jun 2002 22:35:21 +0700
hi Tony
 What method do you used to connect to the database ? nad what database is that ? i suggess if u have a crystal 8.5 then used RDC it
will speed up the calling reportt time and also a lot of enhanced function to be used. beside that just u have mention about the dll
in the clint PC already but to u register this DLl propbely in the client machine ? if not used the regsvr32 to register the dll.
trry used the ADO method to connect to the database instaed of using the connect method

regards
tl wong


_______________________________________________________
WIN a first class trip to Hawaii.  Live like the King of Rock and Roll
on the big Island. Enter Now!
http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes
Message #3 by Tony Cooper <Tony.Cooper@H...> on Mon, 10 Jun 2002 10:05:11 +0100
Hi Wong

Thanks for your input.. I'm using Access2000 and connecting using DAO. From
what you're saying I should be using RDC... Next release of my software
then.

When you mentioned registering of DLLs, that got me looking more deeply. I
have found the answer....

When VS created my msi package, the file dao360.dll was included, however it
wasn't set to Self register as I would have expected.....

All working fine now

Thanks
Tony

-----Original Message-----
From: Wong Tze Lun [mailto:tzelun0502@l...]
Sent: 07 June 2002 16:35
To: crystal_reports
Subject: [crystal_reports] Re: Error File Not Found


hi Tony
 What method do you used to connect to the database ? nad what database is
that ? i suggess if u have a crystal 8.5 then used RDC it will speed up the
calling reportt time and also a lot of enhanced function to be used. beside
that just u have mention about the dll in the clint PC already but to u
register this DLl propbely in the client machine ? if not used the regsvr32
to register the dll.
trry used the ADO method to connect to the database instaed of using the
connect method

regards
tl wong


_______________________________________________________
WIN a first class trip to Hawaii.  Live like the King of Rock and Roll
on the big Island. Enter Now!
http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes


  Return to Index