p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

proasp_codeclinic thread: RV: asp error after office 2000 install


Message #1 by "Cesar Alejandro Brito Espinoza" <abrito@s...> on Sat, 24 Mar 2001 11:53:01 -0600
Check the Microsoft KBase


This is from Kbase, (there are more)
--------------
CAUSE
The "Library not registered" detail string indicates that there is a problem
with the registry information for this object. The registry entry may be
missing or contain incorrect information, or the user may not have
permission to read the registry entry. This article describes how to resolve
the problem when the information in the registry is correct, but the user
does not have permission to read it.

This problem can also occur when you install Crystal Reports 8. For
additional information, click the article numbers below to view the articles
in the Microsoft Knowledge Base:

Q266621 PRB: Error Message: "Library Not registered" Problem with Crystal
Reports 8
Q272693 0x8004005 ASP Error Message Occurs When You Connect to a Database
after Crystal Reports 8 Installation


To resolve this problem, give the Everyone group Read permission to the
ClassID and TypeLib registry entries for the component that is failing.

NOTE: The ClassID and TypeLib registry entries are both long, hexadecimal
numbers known as GUIDs (Globally Unique IDentifiers) or UUIDs (Universally
Unique IDentifiers).

If the problem continues, you can also use the RegMon utility to determine
which attempts to read the registry are failing. You may need to give the
Everyone group Read permissions to other registry keys.




"Exito sin Honor es Fracaso, Ganancia sin Integridad es Perdida"

L.S.C. César Alejandro Brito Espinoza
Seguros Comercial América

-----Mensaje original-----
De: paul.mitchell@b... [mailto:paul.mitchell@b...]
Enviado el: Jueves, 24 de Mayo de 2001 11:33 a.m.
Para: Code Clinic
Asunto: [proasp_codeclinic] asp error after office 2000 install


Server object error 'ASP 0177 : 8002801d'
Server.CreateObject Failed

/itweb/_fpclass/fpdbrgn1.inc, line 99

Library not registered.


This error appears every time I try to access the ASP pages.

The pages worked fine until I installed the Office 2000 server extentions
which run on the local intranet.

Any ideas would be much appreciated as it is now driving me mad.

Thanks

Paul Mitchell

  Return to Index