p2p.wrox.com Forums

Need to download code?

View our list of code downloads.


  Return to Index  

proasp_codeclinic thread: response.redirect and (maybe) request.querystring


Message #1 by "Patrick Mair" <pmair@e...> on Mon, 19 Nov 2001 14:15:33 -0700
kill the leading "/"

-----Original Message-----
From: Patrick Mair [mailto:pmair@e...]
Sent: Tuesday, November 20, 2001 9:50 AM
To: Code Clinic
Subject: [proasp_codeclinic] RE: response.redirect and (maybe)
request.querystring


response.write Request.QueryString("refurl") gives me what it should.  In
the example I've been using it gives /vacation/vacrequest.asp which is
correct.

If I specify response.redirect "/vacation/vacrequest.asp" it works, yet
response.redirect request.querystring("refurl") doesn't -- even though it
holds /vacation/vacrequest.asp.

This problem has cost me enough time though, I thank you all for your help
but I've taken it a different way and used a cookie instead which does work.
:)

Patrick

-----Original Message-----
From: O'Hara, Elliott M [mailto:EMOHARA@k...]
Sent: November 20, 2001 3:37 AM
To: Code Clinic
Subject: [proasp_codeclinic] RE: response.redirect and (maybe)
request.querystring


do a response.write Request.Querystring("refurl")...
What are you getting?

-----Original Message-----
From: Patrick Mair [mailto:pmair@e...]
Sent: Monday, November 19, 2001 5:07 PM
To: Code Clinic
Subject: [proasp_codeclinic] RE: response.redirect and (maybe)
request.querystring


It's executing before the <HTML>.

I've tried it with response.buffer = true to no avail.

I have just tried encoding the variable but that doesn't help me either.
It's response.redirect'ing from a login page to the requested URL page
which I'm passing in through the varible.  Right now it simply reloads the
login page without a querystring upon a successful login when it should be
redirecting.

Somehow,

http://envwork/login/login.asp?REFURL="/vacation/vacrequest.asp"
theurl = request.querystring("refurl")

is NOT equal to:

refurl = "/vacation/vacrequest.asp"

and I can't figure out why...

> Are you executing it after the <HTML> code, that is a no no and try it
with
> response.buffer = true, and url encode your variable.
>
>
> Tim Morford
>


EMOHARA@k...
$subst('Email.Unsub')


pmair@e...
$subst('Email.Unsub')



EMOHARA@k...
$subst('Email.Unsub')

  Return to Index