p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   VB.NET 2002/2003 Basics (http://p2p.wrox.com/forumdisplay.php?f=76)
-   -   Compile Bug (http://p2p.wrox.com/showthread.php?t=10407)

jaucourt March 11th, 2004 12:43 PM

Compile Bug
 
When compiling the current application I'm working on (and have been working on for some time), I regularly get an error of the kind 'btnInitialise is not a member of frmInitialise' - which seems to be a problem with scopes, because said button does exist, just declared as 'Private'. If I change the scope to 'Public' or 'Friend', recompile, then change the scope back to 'Private' and recompile, it works fine. It happens just on this button - although before now it occured on a specific function which I had to do the same procedure on to get it to compile.

Anyone else get this problem, or am I just weird?


Hal Levy March 11th, 2004 04:35 PM

I don't know you well enough to decide if your weird.

I'd delete it all together. Recompile. Save. and then re-add the button. Kinda like getting out of the car and getting back in to fix it :)

Hal Levy
Web Developer, PDI Inc.

NOT a Wiley/Wrox Employee

planoie March 15th, 2004 04:47 PM

I have seen similar things in visual studio.net. Usually happens when I have a complex project or other things clogging the memory. I usually resolve it by closing the solution and/or restarting VS.

Peter
------------------------------------------------------
Work smarter, not harder.


All times are GMT -4. The time now is 01:39 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.