p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   C# (http://p2p.wrox.com/forumdisplay.php?f=22)
-   -   Assemblies (http://p2p.wrox.com/showthread.php?t=12393)

leeperm April 28th, 2004 04:34 PM

Assemblies
 
Can anyone help me with this problem. I have an assembly located on a server. I need this assembly to be used by an application located on another machine. I do not want the assembly to be copied locally. Unfortunately, all the examples that I have seen in deploying C# applications involve either the assembly being located in the same directory or in GAC. The problem with GAC (and I might have done something wrong here) is that if I try to install the application on a machine that does not have the assembly copied locally, the install programs does it anyway. One more thing, I do have the option in properties for copying the assembly locally to false. If anyone could help me with this I would appriciate it. Thank you.


Ankur_Verma April 29th, 2004 02:42 AM

A bit of reading on Shared Assemblies and codeBase settings in application configurations would help you in this regard.

Ankur Verma
.Net and C++ Specialist
Wiley Tech Support

leeperm April 29th, 2004 08:23 AM

Thank you Ankur Verma. I did read about the shared assemblies and also on changing the config file using codebase option. I was hoping for another way of doing it. But again thank you for your help. I will see if I can get it to work using the codebase.

Thank you,

Michael



All times are GMT -4. The time now is 12:19 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.