p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Classic ASP Components (http://p2p.wrox.com/forumdisplay.php?f=68)
-   -   Need guidance (http://p2p.wrox.com/showthread.php?t=16016)

Newkid July 27th, 2004 10:44 AM

Need guidance
 
Hi there !

I need the guidance in this case. I checked it at every aspects but still not able to trace out the error. The problem is as follows :

If some one get registered at dad client website, he gets a password by email. But if someone get registered himself/herself using the domain "midsouth.rr.com" he wouldn't get any such email. I don't know why the same component behaves like that..

I am using CDONT component for sending the emails. Below are the code of that file :

<%@ Language=VBScript %>
<% Response.Expires = -1000 'Makes the browser not cache this page
Response.Buffer = True 'Buffers the content so our Response.Redirect will work
%>
<% If Session("Loggeduser")=False then
Response.Redirect ("/error.asp?user=notauthenticate")
End if %>

<%

Dim strchck, achckarray, i, Rs, found
Set Rs = Server.CreateObject("ADODB.Recordset")
Set Rs1 = Server.CreateObject("ADODB.Recordset")
strchck = Request("selct")
achckarray = split(strchck,",")
found = 0
For i = lbound(achckarray) to ubound(achckarray)
if Request("alclass")="Allow" then
sqlopr="update abcd set adminappr=1 where usernum='"& achckarray(i)&"'"
end if
if Request("delclass")="Delete" then
sqlopr= " Delete from abcd where usernum='"& achckarray(i)&"'"
end if
Conn.Execute (sqlopr)
found = found + 1
Next

For i = lbound(achckarray) to ubound(achckarray)
if Request("alclass")="Allow" then
sqldata = "select * from abcd where usernum='"& achckarray(i)&"'"
Rs.Open sqldata,conn

' Sending an automated reply to the user when it successfully create thier Login.

bdy = "Dear " & Rs("userfname")& " " & Rs("userlname") & vbcrlf
bdy=bdy & vbcrlf
bdy=bdy & "Your account is approved. Below are the details of your account :" & vbcrlf
bdy=bdy & vbcrlf
bdy=bdy & "User ID : " & Rs("userid")& " " & vbcrlf
bdy=bdy & "Password : " & Rs("userpass")& "" & vbcrlf
bdy=bdy & vbcrlf
bdy=bdy & "Regards," & vbcrlf
bdy=bdy & "Webmaster"
Dim NewMail, Body
Set NewMail = Server.CreateObject("CDONTS.NewMail")
NewMail.To= Rs("useremail")
NewMail.From= "Webmaster@abcd.com"
Body= bdy
NewMail.Subject = "Abcd Login Details"
NewMail.Body = Body
NewMail.Bodyformat=1
NewMail.Mailformat=0
NewMail.Send
End if
Next

if found = 0 then
Response.Redirect("pendaccount.asp?err=notchecked" )
else
Response.Redirect("pendaccount.asp")
end if
Rs.Close
Set Rs= Nothing
Rs1.Close
Set Rs1= Nothing
Conn.Close
Set Conn = Nothing
%>

Thanks for your time and co-operation.


With Thanks !
Newkid

bmains July 27th, 2004 11:52 AM

Hello,

Are you actually getting an error, or is no email being received? Can you confirm whether the email is making it by sending it through Outlook or Express, or another client? I wonder if there is a problem in the sent mail, and the email is bouncing back but you aren't getting an error message.

In addition, is it just that domain, or any other ones? For testing purposes, can you send an email to a yahoo.com account?

Brian

Newkid July 27th, 2004 02:54 PM

Hello Brian,

On the top, thanks for the prompt reply. I am not getting an error message but no email being received if someone get registered with the above mentioned domain(midsouth.rr.com). Email id is working fine. I can send & receive email using the same domain id easily.

Look, If the problem is in the code then obviously either I gets the error message or bounced back email like you said. But it's not like that..

I checked the same component with more then 15 domains.. Everywhere I received that password email apart from that midsouth.rr.com domain. Please help me, it's really a miserable problem for me.




With Thanks !
Newkid

bmains July 27th, 2004 04:11 PM

Hey,

That's really weird. I wonder if it's network related. Do you know anything about the network configurations, such as proxy/firewall, etc.?

Brian

Newkid July 27th, 2004 04:23 PM

Hello Brian,

You're true. The problem is really weird.. I am helpless at this momment. I am knocking lots of community forum door for the same issue with a hope that someone can sort out my issue. I am trying very hard to get rid of it. I always want to see my dad smiling face not a dull face..:(

I don't think, it's a network related issue. I am aware about all those things at the age of merely 13 years..

Thanks for your valuable time.


With Thanks !
Newkid


All times are GMT -4. The time now is 01:31 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.