p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Access (http://p2p.wrox.com/forumdisplay.php?f=18)
-   -   Autonumber display in form field (http://p2p.wrox.com/showthread.php?t=23875)

ianc January 14th, 2005 06:53 AM

Autonumber display in form field
 
Hi

I have a form in my database which uses a query combining 2 tables to display information about a contact. One of the fields in the form displays the ID number of the record from one of the tables involved in the query. This field is the primary key for that table and is an autonumber.

My problem is that where the value in the field is 1000 or above it is displayed as a formula rather than a straight figure - e.g. 1194 is displayed as 1.194E+03. Users do occasionally need to refer to the ID number of the record so this isn't very helpful.

Is there anything I can do to sort this out? I imagine it's something quite simple. I've tried playing around with the format setting for the field on the form but that doesn't seem to do anything.

Thanks
Ian


JpJoe January 14th, 2005 06:58 AM

Have you tried adjusting the size of the control displaying the field?

ianc January 14th, 2005 07:11 AM

D'oh!

That seems to have done the trick. I don't really understand why the size of the control should be causing it, since the length of the formula in characters is actually greater than the original number it is rendering, but there you go, problem solved anyway.

Thanks
Ian



All times are GMT -4. The time now is 11:45 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.