p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   PHP How-To (http://p2p.wrox.com/forumdisplay.php?f=98)
-   -   Installing Eclipse IDE in Fedora 3 (http://p2p.wrox.com/showthread.php?t=24579)

Daley January 26th, 2005 06:01 PM

Installing Eclipse IDE in Fedora 3
 
Hi everyone,

I'm a newbie to this forum, and also to Linux, so excuse my ignorance. :)

I've recently installed Fedora 3 on a PC that was formerly Windows, and I've been reasonably happy with it so far. The installation went fine, and the only problem that I've had so far is installing the Eclipse Java IDE 3.0.1

I've downloaded the file from the www.eclipse.org site in the root account, in a .zip format. I selected the "x86 GTK2" option as that was specified for a Intel PC with Red Hat. I then unzipped the file to a folder just off the root directory, and tried clicking on the eclipse cog icon to start up the program. I also unzipped the "startup.jar" file to a subdirectory of the unzipped eclipse folder.

When I clicked on the cog icon to start Eclipse, a error dialog appeared, referring me to a log file in the configuration subdirectory. In it's entirety, this log file said:

!SESSION Jan 26, 2005 20:56:37.134 ---------------------------------------------
eclipse.buildId=M200409161125
java.fullversion=GNU libgcj 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US

!ENTRY org.eclipse.osgi Jan 26, 2005 20:56:37.134
!MESSAGE Startup error
!STACK 1
java.lang.NoClassDefFoundError: while resolving class: org.eclipse.core.runtime.adaptor.EclipseAdaptor
   at java.lang.VMClassLoader.resolveClass(java.lang.Cla ss) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.5.0.0)
   at java.lang.Class.forName(java.lang.String, boolean, java.lang.ClassLoader) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.Class.forName(java.lang.String) (/usr/lib/libgcj.so.5.0.0)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.cr eateAdaptor() (Unknown Source)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.st artup(java.lang.String[], java.lang.Runnable) (Unknown Source)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(java.lang.String[], java.lang.Runnable) (Unknown Source)
   at _Jv_CallAnyMethodA(java.lang.Object, java.lang.Class, _Jv_Method, boolean, boolean, java.lang.Class[], jvalue, jvalue, boolean) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_CallAnyMethodA(java.lang.Object, java.lang.Class, _Jv_Method, boolean, java.lang.Class[], java.lang.Object[]) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[]) (/usr/lib/libgcj.so.5.0.0)
   at org.eclipse.core.launcher.Main.basicRun(java.lang. String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.run(java.lang.Strin g[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.main(java.lang.Stri ng[]) (Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.xml.sax.helpers.DefaultHandler not found in [file:/root/eclipse/plugins/org.eclipse.osgi_3.0.1/core.jar, file:/root/eclipse/plugins/org.eclipse.osgi_3.0.1/console.jar, file:/root/eclipse/plugins/org.eclipse.osgi_3.0.1/osgi.jar, file:/root/eclipse/plugins/org.eclipse.osgi_3.0.1/resolver.jar, file:/root/eclipse/plugins/org.eclipse.osgi_3.0.1/defaultAdaptor.jar, file:/root/eclipse/plugins/org.eclipse.osgi_3.0.1/eclipseAdaptor.jar]
   at java.net.URLClassLoader.findClass(java.lang.String ) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.ClassLoader.loadClass(java.lang.String, boolean) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_FindClass(_Jv_Utf8Const, java.lang.ClassLoader) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_ClassReader.handleClassBegin(int, int, int) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_ClassReader.parse() (/usr/lib/libgcj.so.5.0.0)
   at _Jv_DefineClass(java.lang.Class, byte[], int, int) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.VMClassLoader.defineClass(java.lang.Clas sLoader, java.lang.String, byte[], int, int, java.security.ProtectionDomain) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.ClassLoader.defineClass(java.lang.String , byte[], int, int, java.security.ProtectionDomain) (/usr/lib/libgcj.so.5.0.0)
   at java.security.SecureClassLoader.defineClass(java.l ang.String, byte[], int, int, java.security.CodeSource) (/usr/lib/libgcj.so.5.0.0)
   at java.net.URLClassLoader.findClass(java.lang.String ) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.ClassLoader.loadClass(java.lang.String, boolean) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_FindClass(_Jv_Utf8Const, java.lang.ClassLoader) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_PrepareCompiledClass(java.lang.Class) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_WaitForState(java.lang.Class, int) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.VMClassLoader.linkClass0(java.lang.Class ) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.VMClassLoader.resolveClass(java.lang.Cla ss) (/usr/lib/libgcj.so.5.0.0)
   ...12 more
!SESSION Wed Jan 26 20:56:37 GMT-01:00 2005 ------------------------------------
!ENTRY org.eclipse.core.launcher 4 0 Jan 26, 2005 20:56:37.221
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.NullPointerException
   at _Jv_CallAnyMethodA(java.lang.Object, java.lang.Class, _Jv_Method, boolean, boolean, java.lang.Class[], jvalue, jvalue, boolean) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_CallAnyMethodA(java.lang.Object, java.lang.Class, _Jv_Method, boolean, java.lang.Class[], java.lang.Object[]) (/usr/lib/libgcj.so.5.0.0)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[]) (/usr/lib/libgcj.so.5.0.0)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(java.lang.String[], java.lang.Runnable) (Unknown Source)
   at org.eclipse.core.launcher.Main.basicRun(java.lang. String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.run(java.lang.Strin g[]) (Unknown Source)
   at gnu.gcj.runtime.FirstThread.call_main() (/usr/lib/libgcj.so.5.0.0)
   at gnu.gcj.runtime.FirstThread.run() (/usr/lib/libgcj.so.5.0.0)
   at _Jv_ThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.5.0.0)
   at _Jv_RunMain(java.lang.Class, byte const, int, byte const, boolean) (/usr/lib/libgcj.so.5.0.0)
   at __gcj_personality_v0 (/root/eclipse/java.home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre)
   at __libc_start_main (/lib/tls/libc-2.3.3.so)
   at _Jv_RegisterClasses (/root/eclipse/java.home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre)


I know that I have Java on my machine because I am able to use it fine from the command line.

Any ideas? Is this a common problem when trying to install Eclipse in Fedora? Once again, apologies for my ignorance, I am a Linux newbie. :)

Thanks


Snib January 29th, 2005 01:54 PM

Hey there,

This is a PHP forum. Perhaps you should post this in the Java forum or the Linux forum for better results :-)

hth

-Snib - http://www.snibworks.com
Where will you be in 100 years?

FelAlex February 19th, 2005 06:06 AM

Had the same problem.
It seems there's a problem with java.
My fedora used jdkgcj instead of sun's jdk, and that caused all the trouble, as soon as I've removed that , eclipse worked like charm.
If you do java -version in the terminal, it should print :
java version " your_jdk_version "
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode, sharing)

If it prints u something else, the best thing (I think) is to remove all java packages and reinstall sun's jdk.

If you don't know how or what to do check this : http://community.asiaosc.org/~azman/...ation_fc3.html

Hope this helps.


rajesh007 January 4th, 2006 12:42 PM

Hi FelAlex!
Thank you very much for pointing the error in running the eclipse IDE.
I was also trying my hands without any results to run the eclipse in fedora core 3.

Its running very fine after reinstalling the java.

Rajesh!

sylar April 18th, 2007 07:56 AM

Thans FelAlex
you helped solve my prob too......

Been There Done That
__________________________
http://www.crystalplot.com


All times are GMT -4. The time now is 08:09 PM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.