p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   General .NET (http://p2p.wrox.com/forumdisplay.php?f=122)
-   -   IIS Installation Problem (http://p2p.wrox.com/showthread.php?t=27450)

CricketMaster March 30th, 2005 12:13 AM

IIS Installation Problem
 
Hi,
I am trying to Install IIS.
I have Windows XP professional.
When I try to install it using the windows components wizard I get the message "Cannot copy staxmem.dll Put Windows XP Sp2 in the drive " .

My machine has XP professional factory installed and it has sp2 installed. I still went ahead and put the sp2 disk , hit ok and still get the same error .

I keep reading IIS installation is painless, unfortunately for me it is not. Please help.

Sayian March 30th, 2005 05:38 PM

Try uninstalling SP2
Restart , then goto Windows Update , and re-install SP2 from thier.

If your still having the same problem's , Try contacting Microsoft or searching google for the problem.



CricketMaster April 13th, 2005 09:42 AM

Hello Sayian,
Thanks for your help.
I am not too keen to uninstall SP2 on a factory installed system, especially with all the other security updates that I have put in.

I was hoping somebody has had this problem before and knew exactly what to fix.

Thanks for your help.


pgtips April 13th, 2005 10:01 AM

This was posted to microsoft.public.inetserver.iis on 2004-11-09 08:51:33 PST under subject 'Can't install IIS on fresh Slipstreamed XP SP2'
Quote:

quote:
I called microsoft on this. They admited it was a bug. They sent me this information:

Solution 1:



  1. Run "esentutl /g %windir%\security\database\secedit.sdb" to see if the DB is corrupted.

  2. If so, follow KB 278316

http://support.microsoft.com/default...b;en-us;278316

3. Reboot if necessary

Solution 2:

  1. Create an empty folder on your harddrive called something like "c:\WinXp" (name doesn’t really matter. Just make sure it is empty).

  2. Copy the i386 folder off your original WinXP CD into your new empty folder.

  3. Put your WinXPSP2 CD in your drive.

  4. Open a CMD prompt and change to the location of XPSP2.exe

  5. Type "xpsp2.exe /integrate:c:\WinXp"

  6. Attempt to install IIS again.

  7. When it prompts for files point it to "c:\WinXP"
hope it helps
Phil

CricketMaster April 13th, 2005 12:21 PM

Hello pgtips,
Thank you very much.
Really appreciate your help.
I will try it out tonight and let you know how it goes.
Thanks a million.
:D


CricketMaster April 21st, 2005 10:03 PM

Hello pgtips...
Finally started around 7pm to try the fixes.
I tried both your suggestions ( Database is corrupted ), followed instructions in the link, rebooted, prayed, everything . Same problem. Cannot copy staxmem.dl_.
Googled "staxmem.dl_." , found some good stuff , tried it . Same problem.
Called HP support ( India ) , they asked me to run cmd and then esentutl with more parameters. Same problem.
"When I try to install IIS , cannot copy staxmem.dl_. "
HP gave up, told me to call Microsoft.
Called Microsoft developer support 1-800-936-5800 ( United States ).
By this time it ws 9pm.
Was told support is 8 am to 8pm Chicago time. Monday through Friday.
Today is Thursday. Friday is solid for me form 6am to 9pm.
I will try them Monday around 7pm.
I was told by Microsoft, since this was a installation problem related to .Net, this support would be free.

Will keep you posted of the outcome.
If you can think of anything else I can try , let me know.
Sincerely appreciate your help.
Thank you and God Bless.

P.s I see you are from U.K.
Hope you enjoy a good game of Cricket like me. I have a match this Sunday.



CricketMaster April 23rd, 2005 11:22 AM

Hello and good morning to anyone following this thread.
I did get to Microsoft on time Friday and got through to supprt.
This time they changed their mind and said I have to pay a $250.00 incident fee and they would have a tech help me fix the problem.
I will try a few more things this weekend and if I can't solve it I will pay the $250 to get it resolved. My only fear is they will do something obvious I should have done and I will feel real stupid.
Oh well.
I need to get moving on .net. Its the future.
I will take good notes and hopefully post it for others to use.
Have a nice day.


reyluv May 4th, 2005 03:41 PM


I tried the solution from Microsoft's:
http://support.microsoft.com/?kbid=894351

and it didn't work, probably because the file:
C:\WINDOWS\security\Database\secedit.sdb
was never re-created.

Anyways, I found a solution in google that worked:
esentutl /p %windir%\security\database\secedit.sdb

If you've tried the solution from Microsoft, make sure the file
C:\WINDOWS\security\Database\secedit.sdb
was re-created. If it wasn't, then hopefully you just renamed yours, so rename it back.

Hope this helps.

zenodotnet May 5th, 2005 10:54 AM

Thankyou Saiyan!! You saved me from days of re-ghosting, re-installing and other silliness! I tried every combination of tricks, including the microsoft kb 894351, which like Saiyan says, doesn't work.. but decided not to try the esentutl /p because there are all sorts of warnings and recommendation messages that pop up saying "it is strongly recommended that you run esentutl /r instead" I can't believe the time I spent making a xp2 slipstream CD, uninstalling IIS, uninstalling SP2, and all the other kinds of riddiculous gyrations for 8 straight days!!! (i really wanted my original ghost image of my dying laptop drive to work, and I really needed IIS to work to use visual studio). Thank you!!!!

forever indebted,

zeno

dnkiy December 15th, 2005 11:07 AM

Hi,CricketMaster

   I have the same problem of you ,I hvae no IIS now, sorry ,i am chinese,english is so poor. Do you have ways install IIS now ? please connect me.thanks!
  MSN:dnkiy@163.com
  mail:dnkiywo@gmail.com

thanks very much everyone !



All times are GMT -4. The time now is 01:22 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.