p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Beginning PHP (http://p2p.wrox.com/forumdisplay.php?f=95)
-   -   Yet another Cannot modify header question (http://p2p.wrox.com/showthread.php?t=35263)

TimB November 19th, 2005 09:33 PM

Yet another Cannot modify header question
 
Howdy,

I'm new here and really know nothing about PHP coding. I do, however, want to use TikiWiki and can't login to do anything. I've searched quite a lot for an answer, and if I understand what I've read correctly, I'll need to ask my domain host to place an .ini file in the root on the server. I'm not clear what should be in it, and any help is greatly appreciated. I'll assume that the server admin will know, but I'd like to understand what it is.

A knowledeagle friend tried to fix it and kind of explained about the first msg being sent before the header and such, but I still can't login.

The error when I try to login:

Notice: Only variable references should be returned by reference in /home/jlarthos/public_html/wiki1/lib/adodb/adodb.inc.php on line 2737

Warning: Cannot modify header information - headers already sent by (output started at /home/jlarthos/public_html/wiki1/lib/adodb/adodb.inc.php:2737) in /home/jlarthos/public_html/wiki1/tiki-login.php on line 169

It's a fantastico setup of TikiWiki 1.8.6:

Operating system FreeBSD
Kernel version 5.1-RELEASE
Apache version 1.3.33 (Unix)
PERL version 5.8.7
PHP version 4.4.0
MySQL version 4.0.26

Thanks in advance,
Tim Bush
Ultra Newbie

tonyrosen November 23rd, 2005 10:46 AM

With your header error:

All header information MUST be before ANYTHING else on the page with no white space above it in the code.

Code:

<?
// my header information
?>
<html>


TimB November 26th, 2005 11:43 PM

After trying several fixes I finally just contacted mthe admin guy at the host and he fixed it in about two seconds. Way too simple, but then, I don't know coding 8-)

> The reason being is that we upgraded the servers to php 4.4.0 and apparently TikiWiki
> doesn\t like that.
>
> The solution was actually simple, if you new what to do. There was a reference to line
> 2736 in the adodb.in.php file. That area is a subroutine and starts out as :
> function &FetchRow()
>
> I removed the ampersand (&).
>

And that, as they as, is that!

Thanks,
Tim Bush



All times are GMT -4. The time now is 03:43 PM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.