p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Classic ASP Professional (http://p2p.wrox.com/forumdisplay.php?f=63)
-   -   CreateObject Type mismatch error (http://p2p.wrox.com/showthread.php?t=37773)

Deepmala January 30th, 2006 07:13 AM

CreateObject Type mismatch error
 
Hi all,

We have one web application running on intranet.It uses VB6 component for business logic. Database is SQL.The application is used by about 400 to 500 users.we use CreateObject method to create objects of number of classes from the VB6 dll. whenever number of user's increases it gives "Type mismatch" error for CreateObject method. Here is the sample of the same method we are using,
 Server.CreateObject(Cstr(strComponentName) & ".clsLogin")
strComponentName is the component used.

This comes randomly for any line where CreateObject method is used.
Surprisingly the error gets over after refreshing the page.
It is really problematic to trace the error as it is not consistent.
Kindly let me know any thought on the above case.it'll be helpful.

Thnx in advance!

Regards,
Deepa


Deepmala February 7th, 2006 04:28 AM

Hi all,
After some investigation we found that irrespective of user volume(less/high), when the RAM usage goes beyond 80-85% our we application becomes slow and it starts throwing Type mismatch error message wherever Server.CreateObject method is used. The situation remains the same even if the RAM usage made down until IIS is restarted. Is it a memory problem? Kindly suggest something.
Regards,
Deepmala N

Quote:

quote:Originally posted by Deepmala
 Hi all,

We have one web application running on intranet.It uses VB6 component for business logic. Database is SQL.The application is used by about 400 to 500 users.we use CreateObject method to create objects of number of classes from the VB6 dll. whenever number of user's increases it gives "Type mismatch" error for CreateObject method. Here is the sample of the same method we are using,
Server.CreateObject(Cstr(strComponentName) & ".clsLogin")
strComponentName is the component used.

This comes randomly for any line where CreateObject method is used.
Surprisingly the error gets over after refreshing the page.
It is really problematic to trace the error as it is not consistent.
Kindly let me know any thought on the above case.it'll be helpful.

Thnx in advance!

Regards,
Deepa



All times are GMT -4. The time now is 11:18 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.