p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Pro VB 6 (http://p2p.wrox.com/forumdisplay.php?f=73)
-   -   Error no 70 Permission Denied (http://p2p.wrox.com/showthread.php?t=47858)

rupakroy5 September 14th, 2006 11:13 PM

Error no 70 Permission Denied
 
Hi,

I have developed an application in VB6.0, SQL Server 2000 & Crystal Reports 8.5. OS is Win2000 Prof. with SP4.

There is report which has an OLE object for displaying images at runtime according to the ItemCode. Each ItemCode has got different Image stored in Image folder on Server. This report also has few subreports.

OLE object is linked to a .bmp file in 'C' drive.
As my application runs, it changes the .bmp image in 'C' drive (using Fso object) according to the ItemCode and the changed image is to be reflected on running the report.

Problem is this report works fine some machines but it doesn't working in some machines also. All machines has same configuration.

In one machine it pops-up a message "ERROR No 70 Permission denied.". After that report run successfully without changing the image.

In one machine it doesn't pops-up anything but report runs successfully without changing the image.

In other machines, report runs absolutely fine.

I have gone through the net and found 'dcomconfg' got some setting for solving "Error no 70". I don't know what setting to be changed.

I am also confused for what to do where reports are not working and no error msg are popping.

Please help and advice

Thanks & Regards
rupak






rupakroy5 October 3rd, 2006 11:36 PM

Hi,

Please suggest! ! !

This is very urgent.


Thanks & Regards


gbianchi October 4th, 2006 08:36 AM

hi there..

i get error 70 when i try to delete some folders that were used previously...

the only thing I'm sure if that you get it when you have the file in use...

HTH

Gonzalo

rupakroy5 October 4th, 2006 11:27 PM

Hi,

thanks for the reply.

Well I am using File system object to delete a file and Copy a file.

Actually these are .bmp & .jpg files. Among these files, .bmp file is linked to OLE Object in Report created in Crystal Report 8.5.

I have tried "On Error goto" to check for the error line but failed.

Please suggest



Thanks & Regards




BrianWren October 5th, 2006 12:55 PM

You need to divide the problem into smaller pieces to find out which part is giving you this trouble.

In your code, prior to setting the image, see if you can access the file that you are about to use. If you get the error at that point, then the problem is a file access error.

If you can access the file with no errors, but when you try to point the control at it you get an error, then the control would seem to be the problem (though you could create a small .bmp that everyone has access to, and upon an error with this second part switch to trying to load that all-have-access bitmap to see if that will load fine. If so then the control is OK, the file is OK, but the control does not have the neccessary access to that file that your program [u]does</u> have access to.)

After looking at the individual pieces, and assessing where the problem lies, it will be easier to advise you.

rupakroy5 October 7th, 2006 01:26 AM

Hi,
hanks for the advice.
I am in process to divide the whole application into capsules application.
Let's hope for the best.

Anyway, i have run my application with F8 (line by line execution) on the system which doesn't show the changed image in Crystal report.

Nothing happens. ! ! !

It doesn't throw any error but at the same time image remains the same.

Any Idea!!



Thanks & Regards





All times are GMT -4. The time now is 09:28 AM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.