p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Javascript (http://p2p.wrox.com/forumdisplay.php?f=85)
-   -   Curious image map issue... can you help? (http://p2p.wrox.com/showthread.php?t=50419)

BananaJim November 17th, 2006 06:35 AM

Curious image map issue... can you help?
 
Hi,

I have noticed a strange behaviour on my web page (I am testing with IE6 on a PC). Can you identify the cause?

www.naturalsouls.co.uk/map

As you move the mouse over the list or map, the cursor flickers with the mouse-hourglass cursor. When moving rapidly over the map, you can sometimes get the image to disappear (replaced with X-image box).

Now - if you click a region you will go to a "not found" page (no problem - I just haven't made it yet). NOW - click the back button to go back to the map page. Now you will see that the cursor flicker no longer occurs and the map no longer disappears. I want the behaviour of the map to be like that ALWAYS, even when you first come to the page.

So... what is going on here? Why the flicker? How can I get rid of the problem?

The source is available to view via the browser, of course. Please advise.

Thanks.


erobb November 24th, 2006 01:51 PM

>As you move the mouse over the list or map, the cursor flickers with >the mouse-hourglass cursor. When moving rapidly over the map, you can
>sometimes get the image to disappear (replaced with X-image box).

I suspect the images are not fully loaded when the page is loaded (slow internet connection). So when you roll over the images the image swap is having to trying to finish loading the image

http://www.pageresource.com/jscript/jpreload.htm

I was not able to recreate the behavior you describe in FF or ie7 using a cable connection.

Earl
www.jhdesigninc.com


BananaJim November 29th, 2006 03:10 PM

Hmmm... not sure. The images ARE preloaded on the page (see the source), so there's no reason for them to be re-loaded from the server on rollover.

At least you weren't able to see the glitch, but theoretically it shouldn't happen at all, regardless of IE version.

Anyone have any other ideas on this?



All times are GMT -4. The time now is 02:46 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.