p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   NAnt (http://p2p.wrox.com/forumdisplay.php?f=367)
-   -   Building web application using NANT (http://p2p.wrox.com/showthread.php?t=50427)

ydevesh November 17th, 2006 09:30 AM

Building web application using NANT
 
Hi i am building one simple web application using tool Nant, it's building successfully but when i run the application it's showing this error:-

Could not load type 'WebApplication21.Global'.

Source Error:


Line 1: <%@ Application Codebehind="Global.asax.cs" Inherits="WebApplication21.Global" %>


i am using this build file for building the application:-

<?xml version="1.0"?>
<project name="WebSolution" default="build" basedir="." xmlns="http://nant.sf.net/schemas/nant-0.85.win32.net-1.0.xsd">
    <description>This is a sample build file to be used for the BuildingSolution sample</description>



    <property name="Solution.Filename" value="C:\inetpub\wwwroot\WebSolution\WebSolution. sln"/>
    <property name="Solution.Configuration" value="DEBUG"/>
    <property name="Build.OutputFolder" value="c:\builds\WebSolution\"/>
    <property name="debug" value="true"/>




    <target name="clean" description="remove all generated files">
        <delete>
                  <fileset basedir="${Build.OutputFolder}Latest\">
                        <include name="*.*"/>
                  </fileset>
        </delete>
    </target>

    <target name="build" description="compiles the source code">
            <call target="clean"/>
            <solution solutionfile="${Solution.Filename}" outputdir="${Build.OutputFolder}latest\" configuration="${Solution.Configuration}">
    <webmap>
                <map url = "http://localhost/webapplication21/webapplication21.csproj"
        path = "C:\inetpub\wwwroot\webapplication21\webapplicatio n21.csproj" />
                    </webmap>
    </solution>
    <copy todir ="C:\builds\websolution\latest\">
    <fileset basedir ="c:\inetpub\wwwroot\webapplication21">
    <include name ="**.cs"/>
    <include name ="**.aspx"/>
    <include name ="**.config"/>
    <include name ="**.asax"/>
    </fileset>
    </copy>


    </target>

</project>

is there any mistake in the build file ? pls help me it's very urgent.

Thanks in advance

Devesh


All times are GMT -4. The time now is 12:22 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.