p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   PHP How-To (http://p2p.wrox.com/forumdisplay.php?f=98)
-   -   PHP Configuration Error? (http://p2p.wrox.com/showthread.php?t=51584)

jimmyliew December 15th, 2006 04:20 AM

PHP Configuration Error?
 
Description:
------------
The problem due to I've installed PHP Version 5.2.0. FYI, my system is installed with MySQL Server 5.0 and IIS Version 5.1. The same coding executes with no error message when I tested on my web hosting server. (the error message occur while i test it in my local pc)

my question is, am I missing any setting for my PHP configuration? (FYI, i've follow everything written in PHP Manual Installation Guide).


Reproduce code:
---------------
PHP Notice: Undefined index: username in C:\Inetpub\wwwroot\login\index.php on line 3 PHP Notice: Undefined index: password in C:\Inetpub\wwwroot\login\index.php on line 4 PHP Notice: Undefined index: submit in C:\Inetpub\wwwroot\login\index.php on line 51

Expected result:
----------------
It should work because its working in the old version of PHP which is in
hosting server.

jimmyliew December 15th, 2006 04:27 AM

Really appreciate, if anyone can help me to fix this.
Thanks in advance. :)

Regards,
Jimmy Liew

jhanny007 December 15th, 2006 11:42 AM

hi jim i think youre php.ini you need to set that but anyway i suggest
for the easiest way to connect all sever connection much better to have either of the two the (XAMPP) and (NETSERVER)

xampp includes evry thing such as:

Apache 2.2.3
MySQL 5.0.27
PHP 5.2.0 & PHP 4.4.4
phpMyAdmin 2.9.1.1
FileZilla FTP Server 0.9.20
OpenSSL 0.9.8d
xampp:-->http://www.apachefriends.org/en/xampp-windows.html
netsever: just visit this link (http://sourceforge.net/projects/netserver/)

i hope this can help ;))




jimmyliew December 16th, 2006 06:02 AM

hi jhanny,

Sorry to tell you that the problem still remain.
I tried to install PHPBB forum on my local machine, it works. But weird things is my other php application still remain with errors.

Do you have any advice on it? :) Thanks.

Regards,
Jimmy Liew

jhanny007 December 16th, 2006 06:32 AM

hi

   i think there is another program in your computer which can block your php.....i encountered that kind of problem also my PHP doesn't work well but when i use netserver is worked fine.. I deleted those other program...

 what if you set your local web with local server namely xampp and netserver wherein you dont need to set those php.ini and what so ever...by that if you install one of the two i guess you dont have any problem.....

i hope this can help;))



All times are GMT -4. The time now is 01:50 PM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.