p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Biztalk (http://p2p.wrox.com/forumdisplay.php?f=112)
-   -   BizTalk Server 2006 Standard Restore Problem (http://p2p.wrox.com/showthread.php?t=53766)

stanelisn February 7th, 2007 03:26 PM

BizTalk Server 2006 Standard Restore Problem
 
I have configured BizTalk Server 2006 Standard edition (limited to one BizTalk Group) with BTS server on one box and SQL server on another box.
BizTalk Server on a box called 'BTSTest1' (win2003 Server)
SQL Server which hosts the BizTalk DBs are on a box called 'SQLTest1' (win2k)

I am emulating a restore scenario where I completely reinstalled the OS (win2003 Server, and then BizTalk Server 2006)

I started recoving the BizTalk configuration by opening the BTS configuration console, pointing the SSO database to SQLTest1 (SSODb), applying
configuration, with master secret warning, then backing up my master secret. This works fine and also creates the SSO service on BTSTest1.

I then downloaded the RestoreConfig.vbe which facilitates with the recovery of the BizTalk group for BTS Standard. I run this with the original exported configuration file by running RestoreConfigob.vbe BTSOriginalConfigFile.xml

I open the configuration console and the group information is updated in the configuration UI.

I then edit the username/passwords in the configuration file and import the configuration.

The config file imports and all the data is there.

THE PROBLEM IS that in the BizTalk Server Runtime setup screen, the Create In-Process Host and Instance is checked and there is a warning sign to the left side
of the HostName, which is 'BizTalkServeAppliaction'. The same warning exists for the Isolated Host name. When I click on the warning, it says 'The BizTalk In-Process Host BizTalkServeAppliaction already exists for this group. Only BizTalk In-Process host instance will be created during configuration'.

When I try to apply configuration with this warning, there is a failure message which says 'The WMI class can not be found'. The problem is that all the hosts are already configured in the MsgBox Db, and is reflected within the configuration UI. The BizTalkServeAppliaction service does not exist on the new box and can not be generated due to this error.

HOW do I get the Runtime default service to install and recover the BizTalk server? Does anyone know of this issue?

I have tried deleting all artifacts within the admin console, all adapter handlers, then all host instances and hosts, but it does not let me delete the last default host and then gives me the same error in the configuration. Help!!!!

Also, I have tried deleting all artifacts within the admin console, all adapter handlers, then all adapters, then all host instances and hosts, but when
I tried to install the BizTalk Runtime, and it gives me the error 'Instance of the WMMI class not found. No instance was found with the specified key. This could be a result of the instance being deleted by another BizTalk Admin session'


Thanks, Nick

LENKEN March 25th, 2008 08:28 AM

I currently have the same problem, did you find a solution to your problem?

Thanks,
LENKEN


oliviajones August 2nd, 2013 09:39 AM

Solve Standard Restore Problem
 
To recover BizTalk Server Standard Edition on a 64-bit computer, you must run RestoreConfig.vbe from the 32-bit command prompt so that it can update the 32-bit registry. To open the 32-bit command prompt, click Start, click Run, type c:\windows\syswow64\cmd.exe, and then click OK.

http://www.athenainfotech.co.uk/free-biztalk-health-check


All times are GMT -4. The time now is 12:08 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.