p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   BOOK: Expert One-on-One Access Application Development (http://p2p.wrox.com/forumdisplay.php?f=131)
-   -   Error when trying to run Design Schemes (http://p2p.wrox.com/showthread.php?t=57420)

bschor May 3rd, 2007 10:21 AM

Error when trying to run Design Schemes
 
:(I'm starting simple. System is WinXP SP2, Office XP (2002), Access 2002 SP3. I've created a new (simple so far) DB and am trying to follow Helen's ideas. I've got a simple "Person" table, PersonID primary key, FirstName, LastName, and a few other text fields. I've installed the Design Scheme Addin with no trouble (why does MicroSoft insist on hiding the user's Application folder?), and when I open my new database and run the AddIn Manager, the Design Schemes Addin is right there.

However, when I go to the Forms page and try to create a basic form for my Person table, things go awry. I select Custom Form, put my table in, choose standard everything, and click Finish. I get an immediate Compile Error, Can't Find Project or Library. The Debugger is in Public Function ModuleTextHF(), highlighting the second line of code, the string "Chr$". If I click OK, it stops the debugger and puts me back at Finish. Another push, another error, this time Error 2125, The setting for the FontSize property must be from 1 through 127. An OK here pops me up a blank-looking Form2, nothing on it. There is also a Form1 which resembles the starting Form1 shown as Fig 2.8 in Helen's book.

I noticed in reading the forum that Helen mentioned an error situation that sounds like mine. She said "A misleading error message highlighing a perfectly innocent string manipulation function generally results from a missing (or wrong version) reference. Check your references in the Tools|References dialog, and see if any are marked MISSING. If so, uncheck them and check the version of that library on your computer." I tried to do that, but the References button is greyed out.

... AHA! I may have fixed it! I'm going to continue this post, in hopes it "helps the next guy". I went ahead and opened Form1. I then went to Tools/Macro/VBA Editor, and Tools/References is now available! It DOES have a "Missing" entry, Microsoft Common Dialog Control 6.0, which is not on the list of objects (maybe it has "fixed it"?). Now all I have to do is find this object ...

Well, that's not so easy! Before messing up my system, I'm going to stop, post this, and hope someone answers (soon!).




Bob Schor

bschor May 3rd, 2007 10:34 AM

I've just scoured my hard drive and several CDs (I don't have Visual Studio CDs here). I can find comdlg32.dll in the Windows\System32 folder, but there is no comdlg32.ocx file present. And I'm still getting the error! Help would be most appreciated.

Bob Schor


All times are GMT -4. The time now is 05:26 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.